← Back to team overview

zim-wiki team mailing list archive

Re: Save simple text emails and remove the end of line (manuall line wrapping)


hi, seems i need to change some python permissions(?), im running
under ubuntu 11.04 this Version: 0.50-1
here the -D log:

INFO: Index update done
DEBUG: Loading /home/alejo/.config/zim/customtools/remove line
INFO: Execute custom tool remove line breaks
DEBUG: Wrote /tmp/zim-alejo/tmp-page-source.txt
INFO: Running: ['/tmp/zim-alejo/tmp-page-source.txt',
'/home/alejo/Notes/remove_line_breaks.py.gz'] (cwd: None)
DEBUG: Running ErrorDialog
ERROR: [Errno 13] Permission denied
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/zim/gui/__init__.py", line 1508,
in exec_custom_tool
  File "/usr/lib/pymodules/python2.7/zim/gui/applications.py", line 720, in run
    Application.run(self, args)
  File "/usr/lib/pymodules/python2.7/zim/applications.py", line 85, in run
    subprocess.check_call(argv, cwd=cwd, stdout=open(os.devnull, 'w'))
  File "/usr/lib/python2.7/subprocess.py", line 499, in check_call
    retcode = call(*popenargs, **kwargs)
  File "/usr/lib/python2.7/subprocess.py", line 486, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 672, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1213, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied
INFO: Remove file: /tmp/zim-alejo/tmp-page-source.txt


On Wed, Jul 6, 2011 at 9:18 PM, Jaap Karssenberg
<jaap.karssenberg@xxxxxxxxx> wrote:
> On Wed, Jul 6, 2011 at 5:23 PM, alejo d <alejoduque@xxxxxxxxx> wrote:
>> i tried to run some scripts but always get a permission denied error.
>> have put the scripts both in /usr/local/bin and now they are beside my
>> Notes in /home/Notes...
>> have made the scripts and even a particular note fullly:
>> -rwxrwxrwx
>> but still same error.. im runnig zim as user and both files in
>> question are in a path where i have perms..
>> if anyone has a hint it will be really appreciated.
> Could you run zim in debug mode (zim -D) and check the full error output ?
> -- Jaap


Follow ups