← Back to team overview

zim-wiki team mailing list archive

Unable to get zim 0.73.5 to load a plugin on windows 10



I can't get a plugin to be installed -
https://github.com/Osndok/zim-plugin-nowbutton using 0.73.5 on Windows 10.
I have done a portable installation into C:\work\zim73portable

One issue is that there are *two *plugin folders I can see.
[1] I can see a folder *C:\work\zim73portable\share\zim\plugins* where
there are all the plugin .py files and corresponding pyc files in the
C:\work\zim73portable\share\zim\plugins\__pycache__ folder
[2] In the edit preferences->Plugins->"Open plugins folder" button route,
it says that the plugins folder does not exist and offers to create it -
and it creates *C:\work\data\zim\plugins *(perhaps my $HOME is set to

So I placed the nowbutton.py in *both* the plugins folders and restart zim
The plugin does not appear in the enable plugin dialog list and I cannot
see a .pyc or pyo file that would indicate that zim has tried to load the

Next, I tried running zim.exe from the command line with the --verbose and
--debug options, but the zim.exe process just brings us back to the command
line and launches the GUI without any logs in the terminal.

Q0. Am I missing something basic?
Q1. Where should I actually place the plugin file?
Q2. How do I debug this problem? (I am using Windows 10)

Thanks for your kind help.

Aalhad Saraf

Follow ups