← Back to team overview

zorba-coders team mailing list archive

Re: [Merge] lp:~zorba-coders/zorba/debugger_ctrl_c into lp:zorba

 

Review: Needs Fixing

I tested it. Works really nice. I just have some little comments concerning the code:

1)
Do we already have a bug entry for this:
336	     // TODO: this was the initial implementation. This will have to change
337	-    this->sleep_(1000);
338	+    this->sleep_(250);

2)
Do these lines of code block the default behavior of ctrl-C? If yes, can you please at a comment?
134	+#ifdef WIN32
135	+BOOL WINAPI
136	+ctrlC_Handler(DWORD aCtrlType)
137	+{
138	+  if (CTRL_C_EVENT == aCtrlType) {
139	+    return true;
140	+  }
141	+  return false;
142	+}
143	+#else
144	+void
145	+ctrlC_Handler(int lParam)
146	+{
147	+  //exit(1);
148	+}
149	+#endif
150	+

3)
Strange variable name: theNotBremse :-)
-- 
https://code.launchpad.net/~zorba-coders/zorba/debugger_ctrl_c/+merge/88918
Your team Zorba Coders is subscribed to branch lp:zorba.


References