← Back to team overview

zorba-coders team mailing list archive

Re: [Merge] lp:~zorba-coders/zorba/simplestore-api into lp:zorba

 

Review: Needs Information

- The destroy* functions could also be pure virtual in store.h. Why aren't they?
- With the introduction of a new abstract Store class, the need for types like DocumentSet, CollectionSet, IndexSet somehow disappears because functions such as getDocument only delegate to the corresponding Set. Instead, the implementation could be directly done in the deriving store class. But this is just something to consider and not a must fix.
- Along this argument, the RefNodeMap should be moved into the SimpleStore class because it's unlikely that another store shares the same data structure.
- The counters (i.e. theUriCounter, theCollectionCounter, and theTreeCounter) could go into the SimpleStore subclass. 
-- 
https://code.launchpad.net/~zorba-coders/zorba/simplestore-api/+merge/96360
Your team Zorba Coders is subscribed to branch lp:zorba.


References