← Back to team overview

zorba-coders team mailing list archive

[Merge] lp:~paul-lucas/zorba/bug-1010311 into lp:zorba

 

Paul J. Lucas has proposed merging lp:~paul-lucas/zorba/bug-1010311 into lp:zorba.

Requested reviews:
  Matthias Brantner (matthias-brantner)
  Paul J. Lucas (paul-lucas)
Related bugs:
  Bug #1010311 in Zorba: "ft:thesaurus-lookup() on a non-existant word fails assertion"
  https://bugs.launchpad.net/zorba/+bug/1010311

For more details, see:
https://code.launchpad.net/~paul-lucas/zorba/bug-1010311/+merge/109275

s/ZORBA_ASSERT/if/
-- 
https://code.launchpad.net/~paul-lucas/zorba/bug-1010311/+merge/109275
Your team Zorba Coders is subscribed to branch lp:zorba.
=== modified file 'src/runtime/full_text/ft_module_impl.cpp'
--- src/runtime/full_text/ft_module_impl.cpp	2012-05-19 00:12:15 +0000
+++ src/runtime/full_text/ft_module_impl.cpp	2012-06-08 04:40:27 +0000
@@ -505,12 +505,11 @@
       state->phrase_, state->relationship_, state->at_least_, state->at_most_
     )
   );
-  ZORBA_ASSERT( state->tresult_.get() );
-
-  while ( state->tresult_->next( &synonym ) ) {
-    GENV_ITEMFACTORY->createString( result, synonym );
-    STACK_PUSH( true, state );
-  }
+  if ( state->tresult_ )
+    while ( state->tresult_->next( &synonym ) ) {
+      GENV_ITEMFACTORY->createString( result, synonym );
+      STACK_PUSH( true, state );
+    }
 
   STACK_END( state );
 }


Follow ups