← Back to team overview

ac100 team mailing list archive

Re: suspend breakage vs android 2.2 bootloader?


On Tue, 27 Sep 2011 15:59:28 +0300, Jani Monoses <jani.monoses@xxxxxxxxx>
> I reflashed the Android 2.1 boot partitions and suspend works now!
> Mistery solved but a proper kernel fix is needed imo to cover the bits
> may have been set up by 2.1 for free :)
> This sequence worked after two trials which left the machine
> I used an explicitly separate step for downloading fastboot,
> then waited a bit after the last command.
> sudo LD_LIBRARY_PATH=. ./nvflash --bl fastboot.bin --go
> sudo LD_LIBRARY_PATH=. ./nvflash  --bl ./fastboot.bin --go
--rawdevicewrite 0 1536 tac100-part-2.img
> sudo LD_LIBRARY_PATH=. ./nvflash  --bl ./fastboot.bin --go
--rawdevicewrite 1536 256 tac100-part-3.img
> sudo LD_LIBRARY_PATH=. ./nvflash  --bl ./fastboot.bin --go
--rawdevicewrite 1792 1024 tac100-part-4.img
> Here's a tarball of these 3 partitions as factory defaults for the 10z
> model - should be same for all but who knows.
> http://startx.ro/~jani/bootparts_ac100_z.tgz
> Jani

Actually if you use the nvflash installed from the .deb (here:
http://share.grandou.net/debian/nvflash/ ),
you can just run:
~$ nvflash --bl /usr/lib/nvflash/fastboot.bin --rawdevicewrite 0 1536
Just need to reboot after every rawwrite, as it doesn't seem to like to