← Back to team overview

cloud-init-dev team mailing list archive

[Merge] lp:~gz/cloud-init/apt_get_quiet_1012613 into lp:cloud-init

 

Martin Packman has proposed merging lp:~gz/cloud-init/apt_get_quiet_1012613 into lp:cloud-init.

Requested reviews:
  cloud init development team (cloud-init-dev)
Related bugs:
  Bug #1012613 in cloud-init: "Log for apt-update-upgrade is ugly"
  https://bugs.launchpad.net/cloud-init/+bug/1012613

For more details, see:
https://code.launchpad.net/~gz/cloud-init/apt_get_quiet_1012613/+merge/110041

Use the -q switch when running apt-get to get output suitable for logging, rather than with pretty progress updates designed for interactive use. This makes the log, as returned by GetConsoleOutput for instance, a little shorter and easier to read. Some action completion notices are also missed, but it's pretty clear still as no error output appears before cloud-init goes on to the next thing.
-- 
https://code.launchpad.net/~gz/cloud-init/apt_get_quiet_1012613/+merge/110041
Your team cloud init development team is requested to review the proposed merge of lp:~gz/cloud-init/apt_get_quiet_1012613 into lp:cloud-init.
=== modified file 'cloudinit/CloudConfig/__init__.py'
--- cloudinit/CloudConfig/__init__.py	2012-01-18 14:07:33 +0000
+++ cloudinit/CloudConfig/__init__.py	2012-06-13 11:18:38 +0000
@@ -260,7 +260,7 @@
     e = os.environ.copy()
     e['DEBIAN_FRONTEND'] = 'noninteractive'
     cmd = ['apt-get', '--option', 'Dpkg::Options::=--force-confold',
-           '--assume-yes', tlc]
+           '--assume-yes', '-q', tlc]
     cmd.extend(args)
     subprocess.check_call(cmd, env=e)
 


Follow ups