← Back to team overview

coapp-developers team mailing list archive

Re: Problems using coapp



Hmm. I think I'll add the other in as an alias too...

From: rajat goyal [gyl.rajat@xxxxxxxxx]
Sent: Monday, March 26, 2012 3:30 PM
To: ankit choudhary
Cc: Garrett Serack; coapp-developers@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Coapp-developers] Problems using coapp

Hi Garrett and Ankit ,

I believe this is the correct link  http://coapp.org/install .


On Tue, Mar 27, 2012 at 3:18 AM, ankit choudhary <ankit.goaldecided@xxxxxxxxx<mailto:ankit.goaldecided@xxxxxxxxx>> wrote:
Hi Garrett,

Thanks for the reply.

The path for installer i.e. http://coapp.org/installer is not working. Please provide the working one.


On Tue, Mar 27, 2012 at 2:54 AM, Garrett Serack <garretts@xxxxxxxxxxxxx<mailto:garretts@xxxxxxxxxxxxx>> wrote:
Hey Ankit,

You caught me between fixing things and breaking things..

First, if you’ve got an broken install of CoApp, download the http://coapp.org/cleaner application, and run it, it will clean up anything we’ve got broken.

Second, Download and run the latest installer from http://coapp.org/installer and double click that MSI. It *should* install … if it doesn’t stop, and we’ll see what I’ve broke :)

Third, download the devtools from http://coapp.org/devtools and run that installer. You can also open up an elevated command prompt and run;

coapp install coapp.devtools

If that doesn’t work, stop, and we’ll see what’s broken.

As for building the code, pull updates from github—I just committed some more changes that should fix up the errors.

Then you should be able to build the code from the command line by going into the folder and typing:

ptk debug

to build the debug version of the tools.

If you’re still having trouble, jump on IRC and I’ll see if I can help you out; http://coapp.org/developers/irc.html

From: coapp-developers-bounces+garretts=microsoft.com@xxxxxxxxxxxxxxxxxxx<mailto:microsoft.com@xxxxxxxxxxxxxxxxxxx> [mailto:coapp-developers-bounces+garretts<mailto:coapp-developers-bounces%2Bgarretts>=microsoft.com@xxxxxxxxxxxxxxxxxxx<mailto:microsoft.com@xxxxxxxxxxxxxxxxxxx>] On Behalf Of ankit choudhary
Sent: Monday, March 26, 2012 9:29 AM
To: coapp-developers@xxxxxxxxxxxxxxxxxxx<mailto:coapp-developers@xxxxxxxxxxxxxxxxxxx>
Subject: [Coapp-developers] Problems using coapp


1) I have build Coapp from source on x86 machine running Windows7. I downloaded the packages from coapp package repo<http://coapp.org/pages/packages.html>, but the package is not installing. I have tried running the msi fies directly and also using the "coapp.exe install-package path". But the coapp.exe stops working.

2) I also tried compiling devtools but it failed showing :

" Error    9    Invalid Resx file. Could not find file 'C:\Users\Ankit\project\devtools\output\any\release\bin\native-bootstrap.exe'. Line 139, position 5.    C:\Users\Ankit\project\devtools\Autopackage\Properties\Resources.resx    139    5    autopackage"

 then i commented ( Line 136 to 142 \devtools\autopackage\Properties\Resources.resx)  the error lines and compiled again and it succeeded. But the tool was not working properly, it was showing some bootstrap related error. So what should be done to avoid this error ?

Looking forward for your reply :)


Mailing list: https://launchpad.net/~coapp-developers
Post to     : coapp-developers@xxxxxxxxxxxxxxxxxxx<mailto:coapp-developers@xxxxxxxxxxxxxxxxxxx>
Unsubscribe : https://launchpad.net/~coapp-developers
More help   : https://help.launchpad.net/ListHelp

Rajat Goyal,
Bits Pilani Goa , India

Follow ups