← Back to team overview

compiz team mailing list archive

[Bug 502564] [NEW] After installing NVIDIA 190.53 drivers on a Karmic live boot and running compiz to see if it would work on my system, compiz core dumped.


Public bug reported:

Binary package hint: compiz

I have been having some problems with karmic and compiz since I switched back to nvidia due to terrible ati driver support just to find that compiz does not work anymore.
I decided to try compiz with a fresh install which also only worked with the 173 drivers and messed up window rendering.
My final attemt was to use a live disk and install the 190.53 drivers directly from nvidia which worked until I started 
compiz --replace
A few seconds after starting it in the terminal compiz core-dumped.

ProblemType: Crash
Architecture: i386
AssertionMessage: *** glibc detected *** /usr/bin/compiz.real: double free or corruption (!prev): 0x09e0fcc8 ***
CompizPlugins: [core,move,resize,place,decoration,animation,ccp,dbus,mousepoll,gnomecompat,png,svg,imgjpeg,text,commands,neg,video,wall,snap,scale,scaleaddon,expo,staticswitcher,regex,resizeinfo,workarounds,ezoom,vpswitch,extrawm,fade,session]
Date: Sun Jan  3 10:50:18 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/compiz.real
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Gigabyte Technology Co., Ltd. EP35C-DS3R
NonfreeKernelModules: nvidia
Package: compiz-core 1:0.8.4-0ubuntu2
PciDisplay: 01:00.0 VGA compatible controller [0300]: nVidia Corporation G92 [GeForce 8800 GT] [10de:0611] (rev a2)
ProcCmdLine: initrd=/ubninit file=/cdrom/preseed/hostname.seed boot=casper quiet splash -- BOOT_IMAGE=/ubnkern
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --sm-client-id 103ca2656aceca37e2126251579483068500000054290022 --loose-binding move resize place decoration animation ccp
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
Signal: 6
SourcePackage: compiz
 __kernel_vsyscall ()
 raise () from /lib/tls/i686/cmov/libc.so.6
 abort () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
 ?? () from /lib/tls/i686/cmov/libc.so.6
Title: compiz.real assert failure: *** glibc detected *** /usr/bin/compiz.real: double free or corruption (!prev): 0x09e0fcc8 ***
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/27/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F3e
dmi.board.name: EP35C-DS3R
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF3e:bd03/27/2008:svnGigabyteTechnologyCo.,Ltd.:pnEP35C-DS3R:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnEP35C-DS3R:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: EP35C-DS3R
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
system: distro = Ubuntu, architecture = i686, kernel = 2.6.31-14-generic

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: apport-crash i386

After installing NVIDIA 190.53 drivers on a Karmic live boot and running compiz to see if it would work on my system, compiz core dumped.
You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in ubuntu.

Follow ups