← Back to team overview

compiz team mailing list archive

[Bug 576696] [NEW] After update to Ubuntu 10.04, display was >weird<


Public bug reported:

Binary package hint: compiz

As the summary states, I updated to Ubuntu 10.04 and at the first
restart (and all subsequent ones, until I fixed it), the display was
messed up.

Meaning (in the order I noticed them):
- Some panel icons (Gnome Main Menu, Firefox) were replaced by the Terminal icon.
- There was only one desktop in the panel display.
- I couldn't switch desktops in any way.
- All windows I opened (desktop options, terminal, Firefox) were stuck at the top left corner, (in the case of Firefox noticeable) cropped to about a quarter of the screen, and had no decoration (window border, title bar (the one saying e.g. "Mozilla Firefox").
- I also couldn't enter anything in the terminal. Logging out via GUI worked, though.

Changing the System > Preferences > Appearance worked, but didn't help in any way.
I finally managed to fix this by switching to metacity and then straight back again (without reboot or anything) – suddenly all was fine.
Therefore the bug is probably hard to reproduce, but it can't hurt to report it.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: compiz 1:0.8.4-0ubuntu15
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
CompizPlugins: [core,move,resize,place,decoration,animation,ccp,water,gnomecompat,session,colorfilter,regex,dbus,vpswitch,imgjpeg,video,mousepoll,svg,workarounds,commands,text,resizeinfo,firepaint,ring,png,snap,fade,cube,scale,expo,rotate,scalefilter,scaleaddon,ezoom,switcher]
Date: Fri May  7 00:42:07 2010
EcryptfsInUse: Yes
MachineType: Acer Extensa 5630
PackageArchitecture: all
 Socket 0:
   no product info available
 Socket 0:
   no card
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
ProcCmdLine: root=UUID=a8a35483-96e6-459c-a001-e1cfcde09f3b ro quiet splash
 PATH=(custom, user)
 xserver-xorg 1:7.5+5ubuntu1
 libgl1-mesa-glx 7.7.1-1ubuntu2
 libdrm2 2.4.18-1ubuntu3
 xserver-xorg-video-intel 2:2.9.1-3ubuntu5
 xserver-xorg-video-ati 1:6.13.0-1ubuntu5
SourcePackage: compiz
dmi.bios.date: 12/05/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.25
dmi.board.name: Homa
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.25:bd12/05/2008:svnAcer:pnExtensa5630:pvr0100:rvnAcer:rnHoma:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Extensa 5630
dmi.product.version: 0100
dmi.sys.vendor: Acer
system: distro = Ubuntu, architecture = i686, kernel = 2.6.32-22-generic

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: apport-bug i386 lucid

After update to Ubuntu 10.04, display was >weird<
You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in ubuntu.

Follow ups