← Back to team overview

compiz team mailing list archive

[Bug 793978] [NEW] snapping edges really broke hard with the last update


Public bug reported:

Binary package hint: compiz

some windows had moved when i ran compiz --replace after the package was
updated; so i dragged and held shift to lock them back to their edges
like they were, the window did not settle when the button was released;
and if i tried to snap to 3 edges it actually never stops moving, it
keeps wobbling

so, open a terminal or some other window; drag it (holding alt or just a
regular decorator drag) while holding shift to lock it to an edge or
two, or three; let go of the button. the window drifts from the snap

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic
Uname: Linux 2.6.38-9-generic x86_64
Architecture: amd64
CompizPlugins: [core,crashhandler,composite,opengl,compiztoolbox,imgjpeg,decor,neg,mousepoll,move,resize,regex,imgpng,grid,text,extrawm,copytex,shift,obs,animation,dbus,put,commands,resizeinfo,place,gnomecompat,imgsvg,workarounds,session,wobbly,notification,cube,rotate,scale,expo,scaleaddon,ezoom,staticswitcher]
CompositorRunning: compiz
Date: Tue Jun  7 04:37:33 2011
DistUpgraded: Log time: 2011-03-17 02:39:21.770457
DistroCodename: natty
DistroVariant: ubuntu
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:360b]
   Subsystem: Hewlett-Packard Company Device [103c:360b]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: Hewlett-Packard Compaq Presario CQ60 Notebook PC
PackageArchitecture: all
 PATH=(custom, user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-9-generic root=UUID=d332acb1-e554-4637-84fe-731b5e39212b ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-9.43-generic
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: Upgraded to natty on 2011-03-17 (82 days ago)
dmi.bios.date: 12/15/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.65
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3612
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 09.67
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.65:bd12/15/2010:svnHewlett-Packard:pnCompaqPresarioCQ60NotebookPC:pvrPCID:rvnHewlett-Packard:rn3612:rvr09.67:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: Compaq Presario CQ60 Notebook PC
dmi.product.version: PCID
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.26+git20110604.6dd804c5-0ubuntu0sarvatt~natty
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11.0+git20110605.e8ea8793-0ubuntu0sarvatt~natty
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11.0+git20110605.e8ea8793-0ubuntu0sarvatt~natty
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0+git20110605.bdb396a4-0ubuntu0sarvatt~natty
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug compiz-0.9 natty regression-update ubuntu

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  snapping edges really broke hard with the last update

Follow ups