← Back to team overview

compiz team mailing list archive

[Bug 1069265] [NEW] Compiz hangs at first click anywhere on desktop - can work around by deleting .compiz/session/* first.


Public bug reported:

After upgrading from 12.04 to 12.10, I found that once logged in, I can
move the mouse around and items highlight as I mouseover them, as well
as the launcher seeming to respond appropriately too. Upon first click,
however (whether it be on the launcher, taskbar, or even a right-click
on the desktop) compiz or unity (inextricably linked now?) hangs. The
mouse pointer can be moved about freely, but otherwise no further action
is possible.

It occured to me that perhaps the issue was related to some sort of
configuration issue - maybe leftover bits from 12.04 confusing 12.10. I
tried the guest login, and everything worked flawlessly, possibly
confirming my suspicion.

My next step was to delete .compiz/session from my home directory. Upon
reboot, everything worked fine again. Problem solved? Apparently not -
upon next boot, it hangs again as before. I also find that
.compiz/session has been re-created. Deleting it via a terminal session
then allowed me to reboot to a working desktop, but only once unless I
first delete the contents of .compiz/session

Workaround: As a workaround, I've added a line to /etc/rc.local to delete the contents of .compiz/session at boot time:
     rm /home/my_username/.compiz/session/*

For a more verbose description including troubleshooting steps taken, see:

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: compiz 1:
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
 NVRM version: NVIDIA UNIX x86_64 Kernel Module  304.43  Sun Aug 19 20:14:03 PDT 2012
 GCC version:  gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,regex,animation,mousepoll,imgpng,place,workarounds,move,snap,session,gnomecompat,vpswitch,grid,wall,unitymtgrabhandles,expo,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Sat Oct 20 19:04:07 2012
DistUpgraded: 2012-10-19 19:43:12,592 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 304.43, 3.5.0-17-generic, x86_64: installed
 NVIDIA Corporation G98 [GeForce 9300M GS] [10de:06e9] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. U6V laptop [1043:19b2]
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
 kmod:nvidia_173_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_experimental_304 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use)
 kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
MachineType: ASUSTeK Computer Inc. N80Vb
PackageArchitecture: all
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=ef4a6395-a5b7-4895-8772-98d133e2f07c ro quiet splash
SourcePackage: compiz
UpgradeStatus: Upgraded to quantal on 2012-10-20 (0 days ago)
dmi.bios.date: 12/05/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 207
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: N80Vb
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr207:bd12/05/2008:svnASUSTeKComputerInc.:pnN80Vb:pvr1.0:rvnASUSTeKComputerInc.:rnN80Vb:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: N80Vb
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug compiz-0.9 quantal running-unity ubuntu

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  Compiz hangs at first click anywhere on desktop - can work around by
  deleting .compiz/session/* first.

To manage notifications about this bug go to:

Follow ups