← Back to team overview

compiz team mailing list archive

[Bug 1242451] [NEW] [Regression] Scrolling in unfocused windows of GTK3 programs doesn't work anymore


Public bug reported:


while using Saucy for productive work I discovered a regression
regarding scrolling.

How to reproduce:

- boot Saucy release live image (or an installed version)
- open a window of a GTK3 application (gedit, nautilus, audacious - which one doesn't matter) whose window contains scrollbars (e.g. a larger text file in gedit)
- open a second window (doesn't matter if this is also from a GTK3 app) and bring it upfront, so that it is focused (and mind that it does not completely overlap the first window, e.g. by arranging them side by side)
- Now move the mouse cursor over the overlapping part of the unfocused GTK3 window and try to scroll with the mouse wheel. It doesn't work anymore. Scrolling under those conditions has worked under all previous Ubuntu versions that I know.

Scrolling does still work if the unfocused windows is _not_ a GTK3
window, e.g. GTK2-based Firefox. Thus I assume this is not an intented
new configuration change, but a bug.

This happens independent of overlay scrollbars enabled or disabled and
independent of the chosen GTK3 theme (also with e.g. Adwaita theme).

Further investigation showed that if I use e.g. Saucy Ubuntu Gnome
Remix/Xubuntu live image, this bug does _not_ appear. It seems that the
bug can be tracked down to Compiz, because when I run XFCE and start
Compiz manually, the bug also appears, thus it is not dependent on
Unity. On the other hand, with other window manager like XFWM4/Mutter, I
can't reproduce the bug.

Kind regards,

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: compiz 1:0.9.10+13.10.20131011-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Ist ein Verzeichnis: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
 NVRM version: NVIDIA UNIX x86_64 Kernel Module  319.60  Wed Sep 25 14:28:26 PDT 2013
 GCC version:  gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu8)
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
CheckboxSubmission: b37fefbc97df4ba6a5f7edd504648fe4
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,regex,animation,vpswitch,gnomecompat,place,resize,imgpng,workarounds,mousepoll,move,grid,snap,expo,wall,unitymtgrabhandles,session,fade,ezoom,scale,scaleaddon,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
 [   13.312344] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [   14.679819] init: udev-fallback-graphics main process (1746) terminated with status 1
Date: Sun Oct 20 23:31:02 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
 nvidia-319-updates, 319.60, 3.11.0-12-generic, x86_64: installed
 virtualbox, 4.2.16, 3.11.0-12-generic, x86_64: installed
GraphicsCard: NVIDIA Corporation GF108 [GeForce GT 430] [10de:0de1] (rev a1) (prog-if 00 [VGA controller])
InstallationDate: Installed on 2013-10-19 (1 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: Gigabyte Technology Co., Ltd. P35-DS3
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-12-generic root=/dev/mapper/internal--ssd-root ro quiet splash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/10/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F13
dmi.board.name: P35-DS3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF13:bd07/10/2008:svnGigabyteTechnologyCo.,Ltd.:pnP35-DS3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP35-DS3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P35-DS3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.14.3-3ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Sun Oct 20 23:15:11 2013
xserver.configfile: default
 input        Power Button         KEYBOARD, id 6
 input        Power Button         KEYBOARD, id 7
 input        Logitech USB Laser Mouse MOUSE, id 8
 input        AT Translated Set 2 keyboard KEYBOARD, id 9
 Failed to load /usr/lib/xorg/modules/libglamoregl.so: /usr/lib/xorg/modules/libglamoregl.so: undefined symbol: _glapi_tls_Context
 Failed to load module "glamoregl" (loader failed, 7)
 open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.3-3ubuntu2

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug compiz-0.9 saucy ubuntu

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  [Regression] Scrolling in unfocused windows of GTK3 programs doesn't
  work anymore

To manage notifications about this bug go to:

Follow ups