← Back to team overview

compiz team mailing list archive

[Bug 1425701] [NEW] Unity stopped working after upgrade


Public bug reported:

After an upgrade last week, Unity stopped working.
Ligthdm wallpaper (with ubuntu branding on bottom) after login, mouse visible, screen goes black every a few secs, then back to wallpaper and mouse again. 
Everything worked fine before. Using Ubuntu 14.04.01 (up-to-date), Unity, Nvidia 304-updates drivers.

I installed gnome2 classic to be able to use my Pc in the meantime.
Started unity from tty1 with --log option (output attached). Multiple
compiz (opengl) - Error: FBO is incomplete: GL::FRAMEBUFFER_UNSUPPORTED
(0x8cdd) seems suspicious.

What I tried:
* renamed .compiz, .config, .gconf and .local to force the creation of new default configs. Didn't work.
* I was able to disable Framebuffer objects in opengl compiz plugin. Got Unity to start, extremely slow and unusable, with the screen going black every few seconds, then normal again, then a black region  moving from bottom to top. Enabled FBO option again.
* gnome fallback (compiz) didn't work either, only the Metacity version or gnome3 classic, so I guess it's some compiz-nvidia driver issue.
* Installed new kernel/xorg stack from hardware enablement stack (utopic versions), same issue.
* Tried nouveau drivers, worked "fine" (as fine as nouveau works on my pc, but at least Unity started normally)
* Moved to nvidia 304 drivers (no -updates), same issue there. Nvidia 173 is listed as option but won't install.
* Tried nomodeset kernel option.
* Downgraded kernel, x server and compiz  to original trusty (no trusty-updates, just trusty), same issue there.
* Reinstalled ubuntu 14.04.01, same issue after enabling nvidia driver.
* downloaded ubuntu 14.04.02, same thing.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz 1:0.9.11+14.04.20140409-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-46.75-generic 3.13.11-ckt15
Uname: Linux 3.13.0-46-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Es un directorio: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
 NVRM version: NVIDIA UNIX x86_64 Kernel Module  304.125  Mon Dec  1 19:58:28 PST 2014
 GCC version:  gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: GNOME
Date: Wed Feb 25 17:59:24 2015
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
 nvidia-304-updates, 304.125, 3.13.0-45-generic, x86_64: installed
 nvidia-304-updates, 304.125, 3.13.0-46-generic, x86_64: installed
 NVIDIA Corporation C68 [GeForce 7050 PV / nForce 630a] [10de:053b] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:82b3]
InstallationDate: Installed on 2015-02-23 (2 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64+mac (20140722.2)
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-46-generic root=UUID=6840a05d-d4c2-4c2c-bde3-34c38de5e0cd ro acpi=off noapic nomodeset quiet splash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/19/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0905
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M2N-VM DVI
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev x.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0905:bd12/19/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N-VMDVI:rvrRevx.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1~ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Wed Feb 25 17:58:27 2015
xserver.configfile: default
 input        HID Keyboard Device  KEYBOARD, id 6
 input        HID Keyboard Device  KEYBOARD, id 7
 input        sonixb               KEYBOARD, id 8
 input        USB Optical Mouse    MOUSE, id 9
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.1-0ubuntu2.7

** Affects: compiz (Ubuntu)
     Importance: Undecided
         Status: New

** Tags: amd64 apport-bug trusty ubuntu

** Attachment added: "Unity log showing multiple errors"

You received this bug notification because you are a member of compiz
packagers, which is subscribed to compiz in Ubuntu.

  Unity stopped working after upgrade

To manage notifications about this bug go to:

Follow ups