← Back to team overview

desktop-packages team mailing list archive

[Bug 1460080] Re: HP laserjet 1018 no longer works


Which is the HPLIP which you have actually installed? Is it the 3.15.2
which is part of Ubuntu 15.04 or did you install an HPLIP directly from
HP's site (3.15.4)? I ask because you get

Make and Model: HP LaserJet 1018, hpcups 3.15.4, requires proprietary

but the automatically added info in this bug report reads:

Package: hplip 3.15.2-0ubuntu4.1

Note that your Ubuntu package of HPLIP (3.15.2-0ubuntu4.1) has bug
1422004 fixed. The version from HP does not necessarily contain this

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to hplip in Ubuntu.

  HP laserjet 1018 no longer works

Status in HP Linux Imaging and Printing:
Status in hplip package in Ubuntu:

Bug description:
  My first experience of Ubuntu was Utopic Unicorn, about 2 months ago. I installed HPLIP, so as to use my HP Laserjet 1018 printer, and it all worked fine. On upgrading to Ubuntu 15.04, my printer stopped working. I have tried everything I can think of: upgrading HPLIP, removing HPLIP and installing an alternative driver (foomatic), deleting and adding the printer, nothing works. I have also downloaded and installed all updates to Ubuntu. I have noticed, checking through previous bug reports, that this appears to be a recurring problem: people's HP printers work OK until, on upgrading Ubuntu, they suddenly stopped working. Can it be that beta versions are not being properly tested? Having spent most of yesterday on this problem, and having being seriously ticked off by my boss, about it, I am unwilling to spend further time on it. I was going to include some screens shots to support my case, but I can't see how to do this. Here are some more details:
  As of now:
  listed printers are: Canon ip1900 series
                                     HP Laserjet 1018 (default) / Enabled --> OK / Shared --> OK
                                                                         Description: Hewlett-Packard HP LaserJet 1018
                                                                         Location: tristram-Aspire-5570Z
                                                                         Device URI: usb://HP/LaserJet%201018?serial=LF04EKT
                                                                         Make and Model: HP LaserJet 1018 Foomatic/foo2zjs-z1 (recommended)
                                                                         Printer state: Idle - Sending data to printer.

  Trying to print a test page produces a little box that says: "Submitted - Test page submitted as job (whatever)"
  Noticing that, above, the driver appears to be set to Foomatic, I tried changing it. Now it reads:
                                                                         Make and Model: HP LaserJet 1018, hpcups 3.15.4, requires proprietary plugin

  I pressed the "Print Test Page" button, and got:  "Submitted - Test page submitted as job 64". As usual, nothing happens.
  All this time, the printer is turned on, and connected to my laptop via USB cable, needless to say. On viewing Document print status I have: Job: 64 /User: tristram /Document: Test Page / Printer: Hewlett-Packard-HP-LaserJet-1018 / Size: 1k /Time submitted: 11 minutes ago / Status (printer appears with a red sign) : Stopped - Printer error
  On viewing job attributes, I have (for instance, a screen shot would be really useful here):
  job-more-info: http://localhost:631/jobs/64 (...)
  job-printer-state-message: Filter failed
  job-printer-state-reasons: ['hplip.plugin-error'] (...)
  job-state-reasons: job-completed-with-errors  (...)

  There's more info in this report, but I don't know what you need...

  I hope this is enough for you people to work on. Meanwhile, I'm
  seriously thinking of downgrading my Ubuntu version to what it was
  before, and HPLIP also, except that I don't know for sure what the
  working version was....

  Thank you very much,


  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: hplip 3.15.2-0ubuntu4.1
  ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
  Uname: Linux 3.19.0-18-generic i686
  ApportVersion: 2.17.2-0ubuntu1.1
  Architecture: i386
   E [29/May/2015:09:53:50 -0300] [cups-deviced] PID 12270 (hpfax) stopped with status 1!
   E [29/May/2015:09:54:39 -0300] [cups-deviced] PID 12722 (hpfax) stopped with status 1!
   W [29/May/2015:09:55:28 -0300] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'Hewlett-Packard-HP-LaserJet-1018-Gray..' already exists
  CurrentDesktop: Unity
  Date: Fri May 29 10:00:31 2015
  InstallationDate: Installed on 2015-01-15 (134 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release i386 (20141022.1)
   device for Canon-iP1900-series: usb://Canon/iP1900%20series?serial=C6EDE8
   device for Hewlett-Packard-HP-LaserJet-1018: usb://HP/LaserJet%201018?serial=LF04EKT
  MachineType: Acer, inc. Aspire 5570Z
  Papersize: letter
   Socket 0:
     no product info available
   Socket 0:
     no card
   Canon-iP1900-series: Canon iP1900 series Ver.3.90
   Hewlett-Packard-HP-LaserJet-1018: HP LaserJet 1018 Foomatic/foo2zjs-z1 (recommended)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-18-generic root=UUID=cb168c94-8297-42bf-9400-5acfcb55fdb2 ro quiet splash vt.handoff=7
  SourcePackage: hplip
  UpgradeStatus: Upgraded to vivid on 2015-04-24 (34 days ago)
  dmi.bios.date: 04/10/07
  dmi.bios.vendor: Acer
  dmi.bios.version: v1.3505
  dmi.board.name: Prespa1
  dmi.board.vendor: Acer, Inc.
  dmi.board.version: Not Applicable
  dmi.chassis.type: 1
  dmi.chassis.vendor: Acer, Inc.
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnAcer:bvrv1.3505:bd04/10/07:svnAcer,inc.:pnAspire5570Z:pvrNotApplicable:rvnAcer,Inc.:rnPrespa1:rvrNotApplicable:cvnAcer,Inc.:ct1:cvrN/A:
  dmi.product.name: Aspire 5570Z
  dmi.product.version: Not Applicable
  dmi.sys.vendor: Acer, inc.

To manage notifications about this bug go to:

Follow ups