← Back to team overview

desktop-packages team mailing list archive

[Bug 1312526] Re: Greeter uses previous session even if it is not available


This is particularly bad in Unity Greeter when only one session type is
available - it doesn't even show the control to pick a session meaning
you can never log in without modifying the stored value from a command

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to unity-greeter in Ubuntu.

  Greeter uses previous session even if it is not available

Status in lightdm-gtk-greeter package in Ubuntu:
Status in unity-greeter package in Ubuntu:

Bug description:
  I install using preseed files, and clobber a bit of /etc to configure
  ubuntu to be suitable for users to login with network credentials.  I
  use pam to make a home directory when users login with network

  On first boot, logging into the VTs works fine but I cannot log into
  the lightdm dislpay manager.  If I type my username and password
  right, I get a "Failed to start session" message and get bounced back
  to the start of the login process.

  If, however, I click one of the session types, e.g. 'ubuntu' or
  'fluxbox', then I can log in.  (I've tried uninstalling fluxbox, this
  doesn't seem to help).  At which point I can login, which I believe
  works until I reboot the machine.  (I will test this shortly).

  If I install the lightdm-gtk-greeter package then I do not encounter
  this bug.  Instead, I am automatically logged into the alphabetically
  first session type (at least, if I've got fluxbox available vs. either
  ubuntu or xfce, that seems to be what I get, if only ubuntu is install
  I get an ubunut session by default so I assume the preference is

  It does not seem to matter if I specify a 
  (I have also tried not setting user-session at all)

  in lightdm.conf (well, I haven't tried it with the gtk-greeter, but it
  doesn't matter with the unity greeter).

  I've tried all of the other lightdm-greeter packages, and lightdm-
  greeter-gtk is the only one that does not suffer from this bug.

  the most relvant message in the logs I can find is:

  DEBUG: Seat: Failed to find session configuration true
  Seat: Can't find session 'true'

  What I would expect to happen is to get some default session; getting
  the alphabetically first session is kind-of/sort-of reasonable.  Total
  failure is not.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: lightdm 1.10.0-0ubuntu3
  ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
  Uname: Linux 3.13.0-24-generic x86_64
  NonfreeKernelModules: openafs
  ApportVersion: 2.14.1-0ubuntu3
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Apr 24 22:08:08 2014
   session-setup-script=/bin/sh -l /etc/profile
  SourcePackage: lightdm
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: