← Back to team overview

desktop-packages team mailing list archive

[Bug 1360545] Re: [trusty] [drm] HPD interrupt storm detected on connector DP-1: switching from hotplug detection to polling


[Expired for xserver-xorg-video-intel (Ubuntu) because there has been no
activity for 60 days.]

** Changed in: xserver-xorg-video-intel (Ubuntu)
       Status: Incomplete => Expired

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-intel in Ubuntu.

  [trusty] [drm] HPD interrupt storm detected on connector DP-1:
  switching from hotplug detection to polling

Status in xserver-xorg-video-intel package in Ubuntu:

Bug description:
  I have a haswell motherboard with 3 1080p monitors connected, 2
  directly via HDMI and a 3rd HDMI connected to an active displayport
  dongle. The monitor on the displayport connection had been working
  fairly reliably until I decided to finally upgrade my bios to fix some
  other issues (big mistake, since I late found out its nearly
  impossible to downgrade). Since I upgraded the monitor nearly never
  works, I did get it to show display a few times but I'm not sure how
  that happened. At the moment while researching information to add to
  this post it actually started working for the moment. When I run
  xrandr it causes the screens to blink rapidly for around 30sec-1min.
  Most of the time the system is unresponsive while the monitor is
  plugged in. It appears to occasionally cause the entire desktop to
  stop responding until the mate-session is killed.

  In dmesg I see instances of:

  [   10.053292] [drm] HPD interrupt storm detected on connector DP-1: switching from hotplug detection to polling
  [  240.125029] [drm] HPD interrupt storm detected on connector DP-1: switching from hotplug detection to polling

  Also fwiw I get different errors, and a kernel backtrace, but still no
  display on current drm-intel-nightly from here:


  And of course it all still works fine under Windows 8.1.

  Searching google I see other instances of people with the same problem
  on the i915 driver on other systems like ThinkPad, etc.




  And a few possibly unrelated things in fdo bugzilla

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: xorg 1:7.7+1ubuntu8
  ProcVersionSignature: Ubuntu 3.13.0-34.60-generic
  Uname: Linux 3.13.0-34-generic x86_64

  ApportVersion: 2.14.1-0ubuntu3.3
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Sat Aug 23 01:14:48 2014
  DistUpgraded: Fresh install
  DistroCodename: trusty
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, including running git bisection searches
   Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
     Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
  InstallationDate: Installed on 2014-03-16 (160 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140315)
  MachineType: Gigabyte Technology Co., Ltd. Z87X-UD5H
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-34-generic.efi.signed root=UUID=19efb927-173d-42b5-bb48-163ee5cb72d8 ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 03/18/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F9
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: Z87X-UD5H-CF
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF9:bd03/18/2014:svnGigabyteTechnologyCo.,Ltd.:pnZ87X-UD5H:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ87X-UD5H-CF:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: Z87X-UD5H
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.52-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
  xserver.bootTime: Sat Aug 23 01:11:35 2014
  xserver.configfile: default
   input        Power Button         KEYBOARD, id 6
   input        Video Bus            KEYBOARD, id 7
   input        Power Button         KEYBOARD, id 8
   input        Logitech Unifying Device. Wireless PID:101b MOUSE, id 9
   input        Logitech Unifying Device. Wireless PID:2008 KEYBOARD, id 10

  xserver.logfile: /var/log/Xorg.0.log
   product id                               22746
   vendor                                     GSM
  xserver.version: 2:1.15.1-0ubuntu2

To manage notifications about this bug go to: