← Back to team overview

desktop-packages team mailing list archive

[Bug 1518411] Re: "Maximum number of clients reached", new in Ubuntu 15.10


A little more info, as I've been trying to watch the output of xwininfo
-root -children, as well as xrestop over time.

As I mentioned before, the number of root children keeps growing over
time.  It starts out under 100, and grows over time.  When the "Maximum
number of clients reached" problem started this time, it was at 322
(lower than last time).  However, I also watched the output of "xrestop
-m 1 -b | grep ^[0-9]" over time, and watched it grow from around 42, to
255 when the problem manifested itself (same as last time).  I think
this is more significant, because the 255 seems to be a cap, and it
never goes higher than this.  Is there an 8-bit table somewhere in X
that if it fills up, could cause this syptom?

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.

  "Maximum number of clients reached", new in Ubuntu 15.10

Status in xorg package in Ubuntu:

Bug description:
  In my newly upgraded (from 15.04) Ubuntu 15.10 system, after I've been
  logged in for a while I can no longer open new windows and instead get
  a "Maximum number of clients reached" error.

  This did not happen in 15.04.

  I ran "lsof" on the X server and did not see an excessive number of
  open file descriptors. I ran it again on a newly restarted X server
  and the number of open file descriptors looked about the same.

  I also ran "xlsclients" when the X server was reporting "Maximum
  number of clients reached" and the list of clients looked correct and
  reasonable (and there were less than 30 of them).

  I am happy to collect any additional logs or debugging information to
  help track this down. I don't know where to look further.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: xserver-xorg 1:7.7+7ubuntu4
  ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
  Uname: Linux 4.2.0-18-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Fri Nov 20 13:00:09 2015
  DistUpgraded: 2015-11-17 11:59:09,835 DEBUG enabling apt cron job
  DistroCodename: wily
  DistroVariant: ubuntu
   virtualbox, 5.0.4, 3.19.0-33-generic, x86_64: installed
   virtualbox, 5.0.4, 4.2.0-18-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
   Intel Corporation Crystal Well Integrated Graphics Controller [8086:0d26] (rev 08) (prog-if 00 [VGA controller])
     Subsystem: CLEVO/KAPOK Computer Device [1558:7410]
  MachineType: System76, Inc. Galago UltraPro
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-18-generic root=UUID=821f94aa-97e2-4384-8494-9f510a75877b ro i915.disable_power_well=0 quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to wily on 2015-11-17 (3 days ago)
  dmi.bios.date: 12/12/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 4.6.5
  dmi.board.asset.tag: Tag 12345
  dmi.board.name: W740SU
  dmi.board.vendor: Notebook
  dmi.board.version: Not Applicable
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: Notebook
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd12/12/2013:svnSystem76,Inc.:pnGalagoUltraPro:pvrgalu1:rvnNotebook:rnW740SU:rvrNotApplicable:cvnNotebook:ct9:cvrN/A:
  dmi.product.name: Galago UltraPro
  dmi.product.version: galu1
  dmi.sys.vendor: System76, Inc.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.64-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
  version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu4
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
  xserver.bootTime: Fri Nov 20 12:51:23 2015
  xserver.configfile: default
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.17.2-1ubuntu9
  xserver.video_driver: intel

To manage notifications about this bug go to: