← Back to team overview

desktop-packages team mailing list archive

[Bug 1392725] Re: cups (or lubuntu printer assistant) fills /tmp with a huge number of files


** Also affects: system-config-printer (Ubuntu)
   Importance: Undecided
       Status: New

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to system-config-printer in Ubuntu.

  cups (or lubuntu printer assistant) fills /tmp with a huge number of

Status in “cups” package in Ubuntu:
Status in “system-config-printer” package in Ubuntu:

Bug description:
  On lubuntu 14.10, after a boot problem described here
  https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1392637 I was
  trying to find out what generated a huge number of files in /tmp.

  Although it is difficult to even ls into this directory. "find ."
  ended up starting to list some files (deleting those files is being
  difficult too).  I ended up looking at one of them and it seems that
  cups (or the lubuntu default printer assistant) is the culprit.

  user:fulltmp$ file ./546285ff50f53
  ./546285ff50f53: symbolic link to `/etc/cups/ppd/freebox.ppd'

  What I did is the following : I tried to add a network printer (named
  freebox) using the printer assistant, this gave me some errors such as
  "cups failed with the following message : Success" (if memory serves).
  The printer would not be added, so I ended up adding it directly
  through the cups web interface, which worked. Sorry I do not know
  which step could have generated this "huge" number of files.

  Am deleting them as we speak using an rsync trick I found here
  large-directory-containing-thousands-of-files (but it's still been a
  few hours). The only size "evaluation" I have of this fulltmp is
  through "ls -alh /" which reports 262M. 262M of symlinks, anyone
  estimate how many symlinks that makes ?

To manage notifications about this bug go to: