← Back to team overview

dhis2-devs team mailing list archive

Re: Possible bug with event data capture without the 'ALL' authority?


Hi Abyot,

Thanks for your reply.  It’s good to know that’s the only authority needed – I had included it, but was still getting these odd persistence errors unless the ‘ALL’ authority was also included.

I’ve now upgraded to the latest update of 2.25, and the problem has disappeared!  I’m not sure what happened here – I hadn’t tried restarting the server, so perhaps that fixed something?   Or is someone actively working on permissions/persistence for the web EventCapture app in 2.25, and this was temporarily introduced as a bug?

Anyway, all now seems to be working.

Cheers, Sam.

From: Abyot Asalefew Gizaw <abyot@xxxxxxxxx>
Date: Friday, 11 November 2016 at 07:58
To: Sam Johnson <samuel.johnson@xxxxxxxxxx>
Cc: DHIS2 Developers <dhis2-devs@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Dhis2-devs] Possible bug with event data capture without the 'ALL' authority?


The required authority to save event is either F_TRACKED_ENTITY_DATAVALUE_ADD which is (Add/Update Tracked Entity Data Value)  or ALL.

Abyot A. Gizaw.
Senior Engineer, DHIS2
University of Oslo

On Fri, Nov 11, 2016 at 12:19 AM, Sam Johnson <samuel.johnson@xxxxxxxxxx<mailto:samuel.johnson@xxxxxxxxxx>> wrote:
Hi all, am just-resending this, as it doesn’t seem to have got through to the mailing list (apologies if I end up double-posting).

In my 2.25 instance, I’m running into problems when a user without the ‘ALL’ authority attempts to save an event-without-registration: it caches the data values, but doesn’t save them into the database.

I’m using 2.25, revision 221c5d8 (Wed morning), Chrome 54.0.2840.71 (64-bit),


•         I can successfully open EventCapture, register a new event, and start capturing data.

•         However, when I save, a programStageInstance is created in the database, but no records are saved to the trackedEntityDataValues table.

•         Re-opening the event at first displays the data that was entered (but if the cache is cleared, it will appear empty, since no data has in fact been saved).

•         If the browser is refreshed before clearing the cache, the message “There is data stored locally, please upload to server” appears, even though I’m online.

•         Clicking ‘Update’ starts the upload to server, but it never completes (the logs show a single entry:
* INFO  2016-11-10 13:38:14,583 Import done: 00:00:00.000<tel:00.000> (Clock.java [http-bio-8080-exec-7])

•         After clearing the cache, if the event is opened and fresh data entered, it sometimes updates the existing event, and sometimes creates a duplicate event on the same date; in both cases, the data is just cached, and although two events still appear if the cache is cleared, they are both empty again.

I don’t think this relates to a specific authority, as I’ve tried it with:

•         a role with just selected EventCapture authorities

•         a role with every authority except ‘ALL’

•         a role with the ‘ALL’ authority.
Users with the ‘ALL’ role can successfully capture data, the other two run into this issue.

I also don’t think it relates to sharing, as I’ve opened up data element and program sharing to rw------ for the relevant User Group.  (The program contains only yes/no data elements, so there are no Option Sets to share.)

Is there some other aspect of sharing/authorities I’ve missed?  (The documentation includes an authority for ‘Single Event Without Registration Data Entry’ / ‘F_ANONYMOUS_DATA_ENTRY’, but that’s not available via the UI, and I’m guessing it doesn’t really exist any longer?)

Or is there perhaps a bug in part of the persistence process, which requires ‘ALL’ permissions?  I’m wondering if this bug might have been introduced into 2.25 by a recent update, as I’m pretty sure I successfully captured events using this user/role a week or two ago…

I have a project that’s completely stuck on this, so very grateful for any enlightenment anyone can provide…

Cheers, Sam.

Mailing list: https://launchpad.net/~dhis2-devs
Post to     : dhis2-devs@xxxxxxxxxxxxxxxxxxx<mailto:dhis2-devs@xxxxxxxxxxxxxxxxxxx>
Unsubscribe : https://launchpad.net/~dhis2-devs
More help   : https://help.launchpad.net/ListHelp

Follow ups