dolfin team mailing list archive
-
dolfin team
-
Mailing list archive
-
Message #15020
Re: [HG DOLFIN] Rename GenericVector:get/set/add (double*) to get_local, set_local and add_local.
On Friday 28 August 2009 12:01:00 Garth N. Wells wrote:
> Johan Hake wrote:
> > On Thursday 27 August 2009 10:22:06 DOLFIN wrote:
> >> One or more new changesets pushed to the primary dolfin repository.
> >> A short summary of the last three changesets is included below.
> >>
> >> changeset: 6857:7cedf9cb8e793c64e69819fcabe3630980e94702
> >> tag: tip
> >> user: "Garth N. Wells <gnw20@xxxxxxxxx>"
> >> date: Thu Aug 27 09:21:55 2009 +0100
> >> files: dolfin/ale/HarmonicSmoothing.cpp
> >> dolfin/fem/SystemAssembler.cpp dolfin/io/RAWFile.cpp
> >> dolfin/io/XMLVector.cpp dolfin/la/EpetraVector.cpp
> >> dolfin/la/EpetraVector.h dolfin/la/GenericMatrix.h
> >> dolfin/la/GenericTensor.h
> >> dolfin/la/GenericVector.h dolfin/la/MTL4Vector.cpp
> >> dolfin/la/MTL4Vector.h dolfin/la/PETScVector.cpp dolfin/la/PETScVector.h
> >> dolfin/la/SingularSolver.cpp dolfin/la/Vector.h
> >> dolfin/la/uBLASVector.cpp dolfin/la/uBLASVector.h
> >> dolfin/plot/FunctionPlotData.cpp
> >> dolfin/swig/dolfin_la_get_set_items.i description:
> >> Rename GenericVector:get/set/add(double*) to get_local, set_local and
> >> add_local.
> >
> > Not sure I got this one.
> >
> > Shouldn't the indices that is constructed by:
> >
> > (snippet from PETScVector::get_local)
> >
> > int m = static_cast<int>(size());
> > int* rows = new int[m];
> > for (int i = 0; i < m; i++)
> > rows[i] = i;
> >
> > go from local_range().first to local_range().second instead of the
> > indices of the global vector, when calling this function in parallel?
>
> Yes - I thought I made the change in the PETSc backend but obviously
> forgot.
Ok, would it be natural to have a local_size function too? Just returning
local_range().second - local_range().first
Johan
> Garth
>
> > Johan
> >
> >> changeset: 6856:d9bca57e586e356ebc642a135a74ed3bd361adb7
> >> user: "Garth N. Wells <gnw20@xxxxxxxxx>"
> >> date: Wed Aug 26 22:48:34 2009 +0100
> >> files: dolfin/fem/Assembler.cpp
> >> description:
> >> Remove some comments.
> >>
> >>
> >> changeset: 6855:51f268bf79d79b0de5d3cb20a7cacb35357c81ce
> >> user: "Garth N. Wells <gnw20@xxxxxxxxx>"
> >> date: Wed Aug 26 14:30:18 2009 +0100
> >> files: demo/pde/elasticity/cpp/main.cpp dolfin/fem/Assembler.cpp
> >> description:
> >> Add OpenMP code to assembler (commented out for now).
> >>
> >> ----------------------------------------------------------------------
> >> For more details, visit http://www.fenics.org/hg/dolfin
> >> _______________________________________________
> >> DOLFIN-dev mailing list
> >> DOLFIN-dev@xxxxxxxxxx
> >> http://www.fenics.org/mailman/listinfo/dolfin-dev
> >
> > _______________________________________________
> > DOLFIN-dev mailing list
> > DOLFIN-dev@xxxxxxxxxx
> > http://www.fenics.org/mailman/listinfo/dolfin-dev
Follow ups
References