← Back to team overview

dulwich-users team mailing list archive

[PATCH 0/3] TreeEntry namedtuple and some cleanup.

 

This implements the namedtuple approach for TreeEntry that we discussed on dulwich-users over the past couple of weeks. There's also the start of some C code cleanup.

These are the beginning of a very long patch series that leads to rename detection and log walking. I've probably said this before, but the rest of these patches should start going out in the next week or so. (Shawn Pearce, who reviews most of my Dulwich code for feature compatibility with C git/JGit, is coming back from leave next week and may have more time to devote to this after GitTogether.)


fb97035 Make TreeEntry a namedtuple for clarity.
641793a Subclass TreeEntry in objects.py.
db49f62 _objects: sorted_tree_items cleanup.

 dulwich/_objects.c            |   97 +++++++++++++++++++++-------------------
 dulwich/misc.py               |   54 +++++++++++++++++++++++
 dulwich/objects.py            |   12 +++++-
 dulwich/tests/test_objects.py |   11 +++--
 4 files changed, 123 insertions(+), 51 deletions(-)



Follow ups