← Back to team overview

elementary-dev-community team mailing list archive

Re: Google Summer Of Code


Regarding GSoC, Wikipedia and Google are your friends:

There's plenty of blogposts from project maintainers about GSoC
results for the projects too. And you can always drop into an IRC of
some projects that have participated and just ask for advice.
Surprisingly, it usually works.

Regarding terminal icon bug
(https://bugs.launchpad.net/elementaryos/+bug/1017171), TL;DR: I've
worked it around a while ago, "sudo apt-get dist-upgrade" and a reboot
should fix it. If not, "sudo apt-get install
user-specific-alternatives" and a reboot.

The bug is actually rooted in BAMF (https://launchpad.net/bamf) which
doesn't work well with things launched via Debian alternatives system
(http://wiki.debian.org/DebianAlternatives), probably because it's not
aware of its way of invoking binaries via chained symlinks.

The development story above is in fact accurate, except what was
proposed is an ugly workaround, not a fix. I especially like the "And
then shnatsel told that person that because of something-something it
really wasn't possible." - that's the most concise way to explain it
I've seen so far!

I've eventually worked around the bug by writing a wrapper for
handling invocation of apps via alternatives system more "properly" in
several respects.
First, the application is invoked directly by its name looked up in
$PATH, not by a symlink that confuses BAMF and doesn't take $PATH
hierarchy into account. This fixes the "wrong icon" bug too.
Second, it launches the user-preferred application instead of a
package-maintainer-defined one, so if your preferred web browser is
Firefox, running "x-www-browser" will launch Firefox, not Midori.

Curiously, the terminal icon bug does not seem to occur in Unity, I
believe BAMF uses some other workaround there. I didn't have time to
test other alternatives system names such as "x-www-browser" or
"gnome-text-editor" though. But the wrapper could be useful in Ubuntu
even if it's not affected by this bug.

I've posted to Ubuntu-devel-discuss list about it, refer to my post
for more info on the wrapper:
Getting it in Ubuntu will require more effort though and I don't have
any time to spare for such relatively minor things (blah exams blah
work blah os bugs blah blah).

Sergey "Shnatsel" Davidoff
OS architect @ elementary

Follow ups