← Back to team overview

kernel-packages team mailing list archive

[Bug 1425699] Re: kernel panic on IBM Power8 PPC MAAS ephemeral image


1: Need to add 14.10 images from Releases Stream to even see hwe-u as an option
2: even though hwe-u is an option, it is unusable for commissioning currently (from Releaess).
3: We really need this usable in Releases, it's gating the Power 8 work.

This morning I tried working on this a bit.  Keep in mind, I did this on a non-Power system because I don't have easy access to it right now, and Mike is working on that.

First, I had to install 14.10 installation media from the Releases
stream.  Once that was done, hwe-u became an option.

Next, I clicked acquire node.  Then Edit node.

In the Edit screen, I set the ARCH to amd64/hwe-u, saved that and then
clicked Commission to start the Commissioning process.

The node powered up and failed to boot.  The console says

Booting under MAAS direction...
nomodeset iscsi_target_name=iqn.2004-05.com.ubuntu:maas:ephemeral-ubuntu-amd64-hwe-u-trusty-no-such-image iscsi_target_ip= iscsi_target_port=3260 iscsi_initiator=these-grandmother ip=::::these-grandmother:BOOTIF ro root=/dev/disk/by-path/ip- overlayroot=tmpfs cloud-config-url= log_host= log_port=514
Could not find kernel image: ubuntu/amd64/hwe-u/trusty/no-such-image/boot-kernel


So since setting the arch to amd64/hwe-u failed to boot commissioning, I
changed it to amd64/hwe-t and retried.  hwe-t was successful in booting
the server and commissioning it.

Following commissioning, I attemped to just install the node using hwe-u
after it was commissioned using hwe-t.

I clicked acquire node.  Then Edit Node.

On the Edit Page, I set the arch to amd64/hwe-u, and left the OS and
Release to Default (which is currently set to 14.04).  I then tried to
start the node for deployment.

The node powered on and attempted to TFTP boot, but instead got a TFTP
timeout error.  It then automatically moved to the next NIC and again
got the TFTP timeout, and at this point it just booted what was on the
hard disk.

Could not find kernel image: ubuntu/amd64/hwe-u/trusty/no-such-image/boot-kernel"

Next, for completeness, I re-acquired the node, left arch at hwe-u and
set the OS to Ubuntu and Release to 14.10 to see what would happen.

With those settings, I was able to successfully deploy the system with

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  kernel panic on IBM Power8 PPC MAAS ephemeral image

Status in Maas image builders:
Status in linux package in Ubuntu:
Status in linux source package in Trusty:

Bug description:
  The kernel running on the 14.04 ephemeral image for MAAS when
  commissioning an IBM Power8 PPC server causes a periodic kernel panic.

  This happens intermittently and cannot be forcefully reproduced.

  The kernel version on the image is 3.13.0-27.50-generic according to
  the boot process.

  Attached is the boot process log with the kernel panics.

To manage notifications about this bug go to:

Follow ups