← Back to team overview

kernel-packages team mailing list archive

[Bug 1125136] Re: 05e3:0732 [P8H77-M PRO] Read errors and kernel panic - genesys USB3 internal card reader


** Changed in: linux (Ubuntu)
   Importance: High => Medium

** Changed in: linux (Ubuntu)
       Status: Opinion => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  05e3:0732 [P8H77-M PRO] Read errors and kernel panic - genesys USB3
  internal card reader

Status in linux package in Ubuntu:

Bug description:
  I have an Astrotek USB 3.0 internal card reader in my new computer,
  plugged into the USB3 header on the mainboard. The reader is
  apparently controlled by the Genesys gl3220 chip. It has two LEDs on
  the front: one red to indicate power, the other green to indicate card
  access/read/write. It also has a USB3 port on the front, which seems
  to work fine with USB sticks.

  I have a 16GB SD card from my camera. When I put it in the SD slot, I
  would expect the card to be detected with the option given to open it
  in Nautilus etc. Instead, the green light flashes on and off
  repeatedly. dmesg reports a series of messages related to xHCI
  followed by "Unhandled error code". I will attach an excerpt from
  dmesg from this incident, which was reliably repeatable.

  I have tried some different BIOS settings for the USB system:
  - Firstly I changed xHCI from "Smart Auto" to "Enabled", logged in, then tested again with an old 256MB SD card.  This was mounted automatically but when I tried to create a folder on the card I received a dialogue box reporting an input/output error. Dmesg reported similar xHCI errors as when I tried the 16GB card. I began to file a bug report, and part way through was dumped to a text console with a kernel panic message (which appeared to stem from usb_storage). As I have no other USB devices plugged in I presume this is again from the card reader.

  - Secondly I toggled the ASUS Bios "EHCI handoff", which I think was
  "disabled" by default and I set it to "enabled". With this set I got a
  kernel panic shortly after logging in, but without inserting a card in
  the card reader at all. I have screenshots of these kernel panics if
  they are of use.

  I am writing this bug report having rebooted the computer, reset the
  USB BIOS settings and restarted and the card reader's red power light
  is not on at all, hence the ubuntu-bug-generated output may not show
  the card reader.

  WORKAROUND: The card reader continues to work as expected if the BIOS
  USB setting "xHCI" is set to "enabled".

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: linux-image-generic
  ProcVersionSignature: Ubuntu 3.5.0-23.35-generic
  Uname: Linux 3.5.0-23-generic x86_64
  ApportVersion: 2.6.1-0ubuntu10
  Architecture: amd64
   /dev/snd/controlC0:  oliver     1942 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
  CurrentDmesg: [    5.927548] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
  Date: Thu Feb 14 22:37:43 2013
  HibernationDevice: RESUME=UUID=d9056455-e6ff-497b-acd2-908669c21bc8
  InstallationDate: Installed on 2013-02-06 (7 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
   eth0      no wireless extensions.

   lo        no wireless extensions.
  MachineType: System manufacturer System Product Name
  MarkForUpload: True
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-23-generic root=/dev/mapper/ubuntu-root ro quiet splash vt.handoff=7
   linux-restricted-modules-3.5.0-23-generic N/A
   linux-backports-modules-3.5.0-23-generic  N/A
   linux-firmware                            1.95

  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/10/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1005
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: P8H77-M PRO
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1005:bd12/10/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8H77-MPRO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to: