← Back to team overview

kernel-packages team mailing list archive

[Bug 1427680] Re: AR3012 bluetooth [13d3:3474] on asus n551 not working


** Branch linked: lp:ubuntu/trusty-proposed/linux-lts-vivid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  AR3012 bluetooth [13d3:3474] on asus n551 not working

Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Vivid:
  Fix Committed

Bug description:
  can't configure any bluetooth device with this laptop. bluetooth adapter is recognized and all seem working but it is unable to find any device on a scan.
  i tried installing blueman also but either it is unable to find any device.
  i've also read many posts with bluetooth solutions for 14.04 but none helped to solve the situation.
  i've also tried a mainline kernel (3.19) with no changes.
  currently i'm using 3.13.0-46-generic
  on the attached archive some files taken from the laptop (lspci,lsusb,rfkill list,dmesg |grep Blue,lsmod and the output of hciconfig -a)
  there are no evidences of problems but the bluetooth don't work.
  unluckly even the touchpad don't work so well on this laptop, so having to use the mouse is a pain

  late addition- i forgot to tell, on my dual boot system, the microsoft sculpt mouse bluetooth works as expected on windows 7
  Ubuntu is not able to see any blutooth device, i have tried 2 phones and this ms mouse, and is not seen by the phones also.

  ApportVersion: 2.14.1-0ubuntu3.7
  Architecture: amd64
   /dev/snd/controlC0:  hook       2242 F.... pulseaudio
   /dev/snd/controlC1:  hook       2242 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=4e7d3097-1e36-4191-98d8-df04a9ce48d2
  InstallationDate: Installed on 2012-11-06 (847 days ago)
  InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-46-generic root=UUID=822863c8-1a3d-4ef2-8f89-0a2e8dc58ab9 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.13.0-46.77-generic 3.13.11-ckt15
   linux-restricted-modules-3.13.0-46-generic N/A
   linux-backports-modules-3.13.0-46-generic  N/A
   linux-firmware                             1.127.11
  Tags:  trusty
  Uname: Linux 3.13.0-46-generic x86_64
  UpgradeStatus: Upgraded to trusty on 2015-01-04 (57 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 10/06/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: N551JM.204
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: N551JM
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN551JM.204:bd10/06/2014:svnASUSTeKCOMPUTERINC.:pnN551JM:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnN551JM:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: N551JM
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to: