← Back to team overview

kernel-packages team mailing list archive

[Bug 1499185] Re: after suspend/resume wlan0 missing


David, as per http://support.hp.com/us-en/drivers/selfservice/HP-
Pavilion-TouchSmart-14-b100-Sleekbook/5355021/model/5363290 an update to
your computer's buggy and outdated BIOS is available (F.1B). If you
update to this following https://help.ubuntu.com/community/BIOSUpdate
does it change anything?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see

Please note your current BIOS is already in the Bug Description, so
posting this on the old BIOS would not be helpful. As well, you don't
have to create a new bug report.

Once the BIOS is updated, if the problem is still reproducible, and the
information above is provided, then please mark this report Status
Confirmed. Otherwise, please mark this as Invalid.

Thank you for your understanding.

** Tags added: bios-outdated-f.1b

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  after suspend/resume wlan0 missing

Status in linux package in Ubuntu:

Bug description:
  Running HP Pavilion TouchSmart 14 (Rev: 18FA-110, model: 14-b124us,
  product number: D1G61UA).  BIOS: F.18 (up to date as far as I can tell
  from ftp://ftp.hp.com/pub/softpaq/sp60501-61000/sp60878.html)

  After calling pm-suspend or closing the lid or using the GUI button
  for suspend and then finally resuming by pushing the power button on
  my laptop, my wireless card is aparently disabled.  More than that if
  I use ifconfig to attempt to find the interface, it has be
  unregistered from known network interfaces (i.e. wlan0 is missing when
  you do ifconfig).

  I have also tried the excercise described here to help with isolating the issue: https://wiki.ubuntu.com/DebuggingKernelSuspend
  I have also tried to manually use modprobe -r with no success.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-63-generic 3.13.0-63.103
  ProcVersionSignature: Ubuntu 3.13.0-63.103-generic 3.13.11-ckt25
  Uname: Linux 3.13.0-63-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.13
  Architecture: amd64
   /dev/snd/controlC0:  david      2267 F.... pulseaudio
  Date: Thu Sep 24 02:43:51 2015
  HibernationDevice: RESUME=UUID=3f560fbb-fe96-4fb1-9a02-f6bd13897726
  InstallationDate: Installed on 2014-11-25 (302 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
  MachineType: Hewlett-Packard HP Pavilion TS Sleekbook 14
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-63-generic.efi.signed root=UUID=5080f182-bc82-4425-befd-dad836fc2b39 ro quiet splash vt.handoff=7
   Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
   No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.13.0-63-generic N/A
   linux-backports-modules-3.13.0-63-generic  N/A
   linux-firmware                             1.127.15
   0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/08/2013
  dmi.bios.vendor: Insyde
  dmi.bios.version: F.18
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: 18FA
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 82.27
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnInsyde:bvrF.18:bd02/08/2013:svnHewlett-Packard:pnHPPavilionTSSleekbook14:pvr088A110000355900000320100:rvnHewlett-Packard:rn18FA:rvr82.27:cvnHewlett-Packard:ct10:cvrChassisVersion:
  dmi.product.name: HP Pavilion TS Sleekbook 14
  dmi.product.version: 088A110000355900000320100
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to: