← Back to team overview

kernel-packages team mailing list archive

[Bug 1283003] Re: [Bluetooth + 14.04] Bluetooth headsets are not working after last couple of updates


Currently, on Lubuntu Trusty, I have no problems with Skullcandy Hesh 2 and:
 * kernel 3.13.0-63-generic #103
 * pulseaudio 1:4.0-0ubuntu11.1+kxstudio1 (I did not test with the standard Canonical version, sorry)
 * bluez 4.101-0ubuntu13.1
 * blueman 1.23-git201403102151-1ubuntu

though I will note it's not always as seamless as I would like. I've discovered elsewhere people suggesting that the adapter is turned on after pulse does its check for bluetooth adapters. That leaves you two choices:
 1. pactl load-module module-bluetooth-discover && pulseaudio -k (note actually sending a KILL signal to the daemon may get it unstuck if it's not behaving)
 2. remove the conditional from /etc/pulse/default.pa regarding loading module-bluetooth-discover
neither of which are particularly elegant, but oh well. 

This and similar issues are ultimately an aesthetic issue, though, and
deserve a separate bug report, as this more general one has brown
extensive enough. From my experience, audio sink service (A2DP) *IS*
possible with current versions.

I'm inclined to call this fixed, unless I hear otherwise from folks.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  [Bluetooth + 14.04] Bluetooth headsets are not working after last
  couple of updates

Status in Blueman:
Status in blueman package in Ubuntu:
  Fix Released
Status in bluez package in Ubuntu:
Status in gnome-bluetooth package in Ubuntu:

Bug description:

  I found a bug in Ubuntu 14.04 !

  I tried to pair a bluetooth stereo headset (A2DP compatible). The
  pairing process goes well, but after that I can't select it on the
  audio preferences.

  When I select it, it only shows the last selected item options and don't do anything. (he should switch to the headset output).
  I must mention that it worked very well on Ubuntu 12.04.

  This bug can be in the bluetooth stack or in unity-control-center or
  maybe pulseaudio. I actually have no idea.

To manage notifications about this bug go to: