← Back to team overview

kernel-packages team mailing list archive

[Bug 1283003] Re: [Bluetooth + 14.04] Bluetooth headsets are not working after last couple of updates


I have two notebook computers - a Toshiba and a Fujitsu both of which
are very old and are both dual boot computers with Windows 7 and Ubuntu
14.04 LTE 32 bit. Both computers and both operating systems work fine
with Bluetooth linking to a Bose mini soundlink speaker for playing
music. I use a USB bluetooth dongle for the link and all works well.

However, with a much newer laptop, a Toshiba Satellite Pro C50-A-1K9
running the 64 bit version of Ubuntu 14.04 LTE I cannot get bluetooth to
work despite using the same dongle and the same speaker. The first time
it finds the device, attempts to pair, but asks that a particular 4
digit code be entered from the device. This is of course impossible as
the Bose mini soundlink speaker does not have a keypad! Further attempts
to search for bluetooth devices after this first time find nothing. If I
then go back to the old notepad computers they also cannot find the
device at all with either Windows or Ubuntu 14.04 32 bit. I strongly
suspect that the 64 bit version of Ubuntu 14.04 LTE has sent a code to
the speaker which prevents it linking via bluetooth thereafter.

If anyone else has the Bose mini soundlink speaker and needs to overcome
this problem, then

Perform a factory reset on the speaker by first turning it on then
holding down the bluetooth button for about ten seconds when the speaker
beeps and will now work again with the old computers and windows 7 or
Ubuntu 14.04 LTE 32 bit.

Hope a skilled programmer finds the bug!

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  [Bluetooth + 14.04] Bluetooth headsets are not working after last
  couple of updates

Status in Blueman:
Status in blueman package in Ubuntu:
  Fix Released
Status in bluez package in Ubuntu:
Status in gnome-bluetooth package in Ubuntu:

Bug description:

  I found a bug in Ubuntu 14.04 !

  I tried to pair a bluetooth stereo headset (A2DP compatible). The
  pairing process goes well, but after that I can't select it on the
  audio preferences.

  When I select it, it only shows the last selected item options and don't do anything. (he should switch to the headset output).
  I must mention that it worked very well on Ubuntu 12.04.

  This bug can be in the bluetooth stack or in unity-control-center or
  maybe pulseaudio. I actually have no idea.

To manage notifications about this bug go to: