← Back to team overview

kernel-packages team mailing list archive

[Bug 1514310] Re: 0408:3003 Quanta Computer, Inc. Touchscreen Controller Detected But Doesn't Work


I downloaded and installed the files from the link you provided then
booted using the new kernel. It did not fix the issue.

:~$ uname -r

Actual packages used

** Tags added: kernel-bug-exists-upstream kernel-bug-exists-

** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  0408:3003 Quanta Computer, Inc. Touchscreen Controller Detected But
  Doesn't Work

Status in linux package in Ubuntu:

Bug description:
  I purchased a touchscreen computer that uses a 0408:3003 Quanta
  Computer, Inc. optical multi-touch touchscreen controller but the
  touch feature does not work. I've updated the BIOS to the latest
  version. I've tried multiple kernels, drivers, distros and none fixed
  the issue or worked. The touchscreen works under Windows version 7 and
  up with without manually installing a driver.

  The touchscreen is detected and shows up when checking lsusb,
  xinput_calibrator, xinput --list, and dmesg -- all with no errors that
  I can see.

  In another bug for this controller user elmarikon suggested the following and it did eventually allow single touches to work but the fix is not persistent across reboots.
  xinput set-mode 13 RELATIVE
  xinput set-mode 13 ABSOLUTE
  sudo rmmod hid-multitouch
  sudo modprobe hid-multitouch

  Ubuntu Version (lsb_release -rd)
      Description:	Ubuntu 15.10
      Release:	15.10

  Kernel Version (cat /proc/version_signature)
      Ubuntu 4.2.0-17.21-generic 4.2.3

  xinput --list
      ↳ Quanta Computer OpticalTouchScreen id=12 [slave pointer (2)]

      Bus 001 Device 005: ID 0408:3003 Quanta Computer, Inc.

      hid 118784 7 hid_multitouch,usbhid,hid_logitech_dj,hid_logitech_hidpp

  dmesg (most recent output after many attempts following elmarikon's "fix")
      input: Quanta Computer OpticalTouchScreen as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/0003:0408:3003.0007/input/input16
      hid-multitouch 0003:0408:3003.0007: input,hiddev0,hidraw4: USB HID v1.10 Mouse [Quanta Computer OpticalTouchScreen] on usb-0000:00:1a.0-1.6/input0
      hid-multitouch 0003:0408:3003.0007: usb_submit_urb(ctrl) failed: -1
      hid-multitouch 0003:0408:3003.0007: usb_submit_urb(ctrl) failed: -1

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-17-generic 4.2.0-17.21
  ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
  Uname: Linux 4.2.0-17-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
   /dev/snd/controlC1:  portal     1106 F.... pulseaudio
   /dev/snd/controlC0:  portal     1106 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Sun Nov  8 23:34:40 2015
  HibernationDevice: RESUME=UUID=72107d2b-667e-4e55-9eab-dfc18a940de3
  InstallationDate: Installed on 2015-11-09 (0 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: Gateway ZX6961
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-17-generic.efi.signed root=UUID=fc9edda2-408b-4a6d-8733-525acc239e95 ro quiet splash vt.handoff=7
   linux-restricted-modules-4.2.0-17-generic N/A
   linux-backports-modules-4.2.0-17-generic  N/A
   linux-firmware                            1.149.2
  SourcePackage: linux
  StagingDrivers: r8712u
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/22/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P01-B3
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: ZX6961
  dmi.board.vendor: Gateway
  dmi.chassis.type: 13
  dmi.chassis.vendor: Gateway
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP01-B3:bd07/22/2011:svnGateway:pnZX6961:pvr:rvnGateway:rnZX6961:rvr:cvnGateway:ct13:cvr:
  dmi.product.name: ZX6961
  dmi.sys.vendor: Gateway

To manage notifications about this bug go to: