← Back to team overview

kernel-packages team mailing list archive

[Bug 1264311] Re: BCM43142 bluetooth adapter not finding any bluetooth devices


I got a Broadcom BCM43142 adapter in my Lenovo notebook and currently I am at a loss getting bluetooth to work with kernels later than 3.13.0-44-generic builds.
The ID of the bluetooth component is 105b:e065 and with a 3.13.0-44 kernel putting the file fw-105b_e065.hcd into /lib/firmware/ does the trick. However, any later kernels I have tried so far up to 4.2.0-19-generic fail to load the bluetooth driver. 
Morever, I have tried to rename the firmware file to BCM43142A0-105b-e065.hcd and putting it into /lib/firmware/brcm in vain.  I just can't get it to work.

What specifically is wrong with those later kernels making them fail to
load? What can I do to fix it? And will it ever be fixed?

Maybe Pilot6 can enlighten me about the root of the problem, as he seems
to have figured something out.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  BCM43142 bluetooth adapter not finding any bluetooth devices

Status in bluez package in Ubuntu:

Bug description:
  On my officially Ubuntu-certified Lenovo B590 laptop the BCM43142
  bluetooth adapter is not working. I have two further bluetooth devices
  placed closely to the laptop, non-paired and each being able to
  discover the other respectively. None of them is able to discover the
  laptop, nor does 'hcitool scan' on the laptop find any devices. It
  does not give any errors though.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.10
  Package: bluez 4.101-0ubuntu8b1
  ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
  Uname: Linux 3.11.0-14-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.12.5-0ubuntu2.2
  Architecture: amd64
  Date: Thu Dec 26 15:34:08 2013
  InstallationDate: Installed on 2013-12-25 (0 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
  InterestingModules: bnep rfcomm btusb bluetooth
  MachineType: LENOVO 37613EG
  MarkForUpload: True
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-14-generic root=UUID=c379c17a-9869-47a8-b9b3-83be4e302040 ro acpi_backlight=vendor quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/26/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: H9ET74WW(1.11)
  dmi.board.asset.tag: Not Available
  dmi.board.name: 37613EG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvrH9ET74WW(1.11):bd06/26/2013:svnLENOVO:pn37613EG:pvrLenovoB590:rvnLENOVO:rn37613EG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 37613EG
  dmi.product.version: Lenovo B590
  dmi.sys.vendor: LENOVO
   hci0:	Type: BR/EDR  Bus: USB
   	BD Address: 1C:3E:84:E8:81:98  ACL MTU: 1021:8  SCO MTU: 64:1
   	RX bytes:1244 acl:0 sco:0 events:81 errors:0
   	TX bytes:2820 acl:0 sco:0 commands:77 errors:0

To manage notifications about this bug go to: