← Back to team overview

kernel-packages team mailing list archive

[Bug 1482435] Re: Wi-Fi not working after Sleep


Gilbert Dion, this bug report is being closed due to your last comment
regarding you don't have access to the hardware. For future reference
you can manage the status of your own bugs by clicking on the current
status in the yellow line and then choosing a new status in the revealed
drop down box. You can learn more about bug statuses at
https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time
to report this bug and helping to make Ubuntu better. Please submit any
future bugs you may find.

** Changed in: linux (Ubuntu)
       Status: Incomplete => Invalid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Wi-Fi not working after Sleep

Status in linux package in Ubuntu:

Bug description:
  After sleep mode, the Wi-Fi chip is not recognized by the kernel
  module and therefore is not available. It is recognized after a reboot
  or after hibernating though.

  I have tried a lot of possibilities. Someone suggested the following command:
  sudo nmcli nm sleep false
  But it does nothing.

  This has nothing to do with the hardware Wi-Fi switch. I know its
  purpose and tried switching on and off.

  Also, the output of the command nmcli nm, nmcli c and nmcli d after
  coming back from sleep mode is showed below. Notice nmcli d shows no
  wlan1 device (which is how my wireless device is identified normally).

  mario@mario-Compaq-Presario-laptop:~$ nmcli nm
  actif           connecté        activé          activé     activé          activé    

  mario@mario-Compaq-Presario-laptop:~$ nmcli c
  NOM                       UUID                                   TYPE              TIMESTAMP-REAL                    
  Connexion filaire 1       cdf0b2eb-484c-4cb9-85fe-ca2d4b717505   802-3-ethernet    mar 04 aoû 2015 23:06:56 EDT      
  JeLisVosCourriels         dcefe472-5b7b-4ae5-9066-0acdf1aec24b   802-11-wireless   mar 04 aoû 2015 22:57:57 EDT      

  mario@mario-Compaq-Presario-laptop:~$ nmcli d
  PÉRIPHÉRIQUE TYPE              ÉTAT         
  eth1       802-3-ethernet    connecté 

  Last but not least, the output of dmesg | grep iwl  (after sleep) is 
  [  693.890526] iwl3945 0000:01:00.0: bad EEPROM signature,EEPROM_GP=0x00000007
  [  693.890532] iwl3945 0000:01:00.0: EEPROM not found, EEPROM_GP=0xffffffff
  [  693.890563] iwl3945 0000:01:00.0: Unable to init EEPROM
  [  693.890713] iwl3945: probe of 0000:01:00.0 failed with error -2

  And I think this tells it all.

  Ubuntu release 14.04 Ubuntu 14.04.2 LTS
  Wi-Fi chip is Intel 3945ABG and module is iwl3945.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.16.0-45-generic 3.16.0-45.60~14.04.1
  ProcVersionSignature: Ubuntu 3.16.0-45.60~14.04.1-generic 3.16.7-ckt14
  Uname: Linux 3.16.0-45-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.14.1-0ubuntu3.11
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Thu Aug  6 19:49:20 2015
  InstallationDate: Installed on 2015-07-25 (12 days ago)
  InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
  SourcePackage: linux-lts-utopic
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: