← Back to team overview

kernel-packages team mailing list archive

[Bug 1528140] Re: USB hub stops working after upgrade


Before starting the bisect, I would like to propose to test kernel I've
uploaded here:


It is simply kernel 3.13.0-74.118 with upstream commit e210c422b6fd
("xhci: don't finish a TD if we get a short transfer event mid TD")
reverted.  This commit is known to have caused regressions and could be
the issue here.  Could you please see if it solves this bug and report

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  USB hub stops working after upgrade

Status in linux package in Ubuntu:

Bug description:
  My laptop is a Dell XPS 13 with Ubuntu 14.04. I use an Inateck USB 3.0 hub with 3 ports and a gigabit ethernet port.
  It worked fine until the upgrade of last week (Thursday 17th December).

  Now the mouse and keyboard do not work anymore when plugged in the usb
  hub. However, when plugged directly in an usb port of the laptop they
  work fine. The ethernet port on the hub still works.

  I just did an upgrade again today in the hope the problem would be solved but it isn't.
  This is my current version: Ubuntu 3.13.0-74.118-generic 3.13.11-ckt30

  Here are a few lines from dmesg, with USB3 related stuff. When I
  executed the command, my Logitech mouse and keyboard were connected -
  but not working. LAN was disconnected when I ran the command.

  [  380.612889] usb 3-1: USB disconnect, device number 2
  [  380.612899] usb 3-1.1: USB disconnect, device number 3
  [  380.613018] usb 3-1.1: Failed to set U1 timeout to 0x0,error code -19
  [  380.613026] usb 3-1.1: Failed to set U1 timeout to 0xff,error code -19
  [  380.613031] usb 3-1.1: Failed to set U2 timeout to 0xff,error code -19
  [  380.613122] ax88179_178a 3-1.1:1.0 eth1: unregister 'ax88179_178a' usb-0000:00:14.0-1.1, ASIX AX88179 USB 3.0 Gigabit Ethernet
  [  380.648657] usb 3-1.1: Failed to set U1 timeout to 0x0,error code -19
  [  380.648676] usb 3-1.1: Failed to set U1 timeout to 0x29,error code -19
  [  380.648680] usb 3-1.1: Failed to set U2 timeout to 0x28,error code -19
  [  463.884120] usb 3-1: new SuperSpeed USB device number 4 using xhci_hcd
  [  464.139316] usb 3-1: New USB device found, idVendor=2109, idProduct=0812
  [  464.139326] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  [  464.139331] usb 3-1: Product: USB3.0 Hub
  [  464.139335] usb 3-1: Manufacturer: VIA Labs, Inc.
  [  464.141383] hub 3-1:1.0: USB hub found
  [  464.512608] usb 3-1.1: new SuperSpeed USB device number 5 using xhci_hcd
  [  464.535497] usb 3-1.1: New USB device found, idVendor=0b95, idProduct=1790
  [  464.535504] usb 3-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  [  464.535509] usb 3-1.1: Product: AX88179
  [  464.535512] usb 3-1.1: Manufacturer: ASIX Elec. Corp.
  [  464.535515] usb 3-1.1: SerialNumber: 000000000005C2
  [  464.860924] ax88179_178a 3-1.1:1.0 eth0: register 'ax88179_178a' at usb-0000:00:14.0-1.1, ASIX AX88179 USB 3.0 Gigabit Ethernet, 00:23:56:4c:07:28

  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
   /dev/snd/controlC1:  alain      2727 F.... pulseaudio
   /dev/snd/controlC0:  alain      2727 F.... pulseaudio
  CurrentDesktop: Unity
   # This is a distribution channel descriptor
   # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=7078d8fd-8d15-4f2d-87cd-892653ec8158
  InstallationDate: Installed on 2014-10-21 (425 days ago)
  InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20130203-13:50
  MachineType: Dell Inc. XPS13 9333
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-74-generic root=UUID=7411b5a6-c0b2-4a68-8a38-a91f38086700 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.13.0-74.118-generic 3.13.11-ckt30
   linux-restricted-modules-3.13.0-74-generic N/A
   linux-backports-modules-3.13.0-74-generic  N/A
   linux-firmware                             1.127.19
  Tags:  trusty
  Uname: Linux 3.13.0-74-generic x86_64
  UpgradeStatus: Upgraded to trusty on 2014-10-29 (417 days ago)
  UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 09/11/2014
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A05
  dmi.board.name: 0D13CR
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.chassis.version: 0.1
  dmi.modalias: dmi:bvnDellInc.:bvrA05:bd09/11/2014:svnDellInc.:pnXPS139333:pvr:rvnDellInc.:rn0D13CR:rvrA00:cvnDellInc.:ct8:cvr0.1:
  dmi.product.name: XPS13 9333
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: