← Back to team overview

kernel-packages team mailing list archive

[Bug 1524939] Re: Using telephony in car with bluetooth not possible after second connection


would like to comment again on this bug to confirm it.
Big progress was made recently in rc-proposed about calls with bluetooth audio car. It works again now (since rc-proposed 03-10-2016). 

But the bug described above is still effective. At a second automatic
reconnection, it's no more possible to use handsfree car system to do a
call. You have to disconnect and reconnect manually the bluetooth device
to solve the problem

Does someone know the commands lines to do this (ie. disconnect and
reconnect to a bluetooth device) ? Will try to put a shorcut in terminal
to do this because it's a bit tricky to do this with the UI while

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  Using telephony in car with bluetooth not possible after second

Status in bluez package in Ubuntu:
Status in ofono package in Ubuntu:

Bug description:
  I've a problem using telephony with bluetooth in my car

  I explain : 
  I can connect in bluetooth with my car
  At the first connection everything works fine (I can do a call, play music normally in car speakers)
  At the second automatic connection (ie. I leave the car and go away, lost the bluetooth connection, and come back in the car --> the phone reconnect automatically to the car bluetooth)

  At this second connection, I loose the possibility to do a call with
  audio in car speakers. Telephony app detect the bluetooth well
  (bluetooth icon in app), but this doesn’t cut the sound already
  playing in car speaker and phone call is not redirected to car
  speakers. When I hangout the sound playing in car speaker is cut (for
  2sec) but if do an other call this still not working.

  So to solve the problem, I have to manually disconnect from car bluetooth and reconnect again (in settings). If I just turn off bluetooth then turn it back on, the problem is not solved.

  Does someone have the same issue or am I not clear ? 
  I could try to add a syslog if it could help.

  Device : mako rc-proposed; Bluetooth car module :  XCARLink Smart BT
  in 207 Peugeot

To manage notifications about this bug go to: