← Back to team overview

kernel-packages team mailing list archive

[Bug 1499556] Re: Computer Reboots Instead of Halting


<b>Workaround</b> and update that may aid in debugging.

I have learned recently (through extensive testing) that pm-hibernate
works flawlessly!  As a workaround I set KDE to hibernate when the power
button is pressed and not ask for a password on resume.  Now I can press
the power button and the machine "hibernates" which, for some reason,
successfully gets the computer to poweroff instead of just rebooting.

I followed this guide to enable hibernation on KDE in Ubuntu 14.04 LTS:
https://help.ubuntu.com/14.04/ubuntu-help/power-hibernate.html   Don't
forget you have to reboot the machine before the settings take effect,
and I had to set the .pkla file rwx for everybody (i.e., sudo chmod 777
).  Then it worked great.

The settings for the power button in KDE are in systemsettings -> power
management -> energy saving and systemsettings -> power management ->
advanced settings

Please keep me posted if this bug every gets fixed, but I'm happy to
have found a better workaround than always holding the power button for
5 seconds to force a poweroff.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Computer Reboots Instead of Halting

Status in linux package in Ubuntu:

Bug description:
  With Ubuntu 14.04 LTS, everytime I try to shutdown my system reboots instead. I have tried a variety of shutdown methods including:
  sudo init 0
  sudo shutdown -P now
  sudo shutdown now
  sudo shutdown -h now
  sudo shutdown -H now
  sudo shutdown -HP now
  (all previous variants with "now" replaced with "1")
  shutting down via the KDE menu (clicking the menu, clicking 'leave' section, clicking shutdown in the dialog box).

  The system hard shuts down if I hold the power button for 5 seconds.

  I have attached a zip of my entire /var/log directory.

  ApportVersion: 2.14.1-0ubuntu3.15
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: kwin
  CurrentDesktop: KDE
  DistUpgraded: Fresh install
  DistroCodename: trusty
  DistroRelease: Ubuntu 14.04
  DistroVariant: kubuntu
  DkmsStatus: fglrx-core, 15.200, 3.16.0-50-generic, x86_64: installed
   Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8330] [1002:9832] (prog-if 00 [VGA controller])
     Subsystem: ASRock Incorporation Device [1849:9832]
  InstallationDate: Installed on 2015-08-21 (53 days ago)
  InstallationMedia: Kubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150219.1)
   QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
   QFileSystemWatcher: failed to add paths: /var/lib/lightdm/.config/ibus/bus
   Bus::open: Can not get ibus-daemon's address.
   IBusInputContext::createInputContext: no connection to ibus-daemon
   file:///usr/share/kde4/apps/lightdm-kde-greeter/themes/userbar/main.qml:135: Unable to assign [undefined] to QString usersession
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  NonfreeKernelModules: fglrx
  Package: xorg 1:7.7+1ubuntu8.1
  PackageArchitecture: amd64
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-50-generic root=UUID=13cf69b2-83fd-4907-ba34-fa3e24e8294a ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.16.0-50.67~14.04.1-generic 3.16.7-ckt16
  Tags:  trusty kubuntu
  Uname: Linux 3.16.0-50-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo users
  _MarkForUpload: True
  dmi.bios.date: 10/27/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P1.00
  dmi.board.name: QC5000-ITX/PH
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.00:bd10/27/2014:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnQC5000-ITX/PH:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.
  version.compiz: compiz N/A
  version.fglrx-installer: fglrx-installer N/A
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.60-2~ubuntu14.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri N/A
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
  xserver.bootTime: Tue Oct 13 20:01:14 2015
  xserver.configfile: default
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.16.0-1ubuntu1.2~trusty2
  xserver.video_driver: fglrx

To manage notifications about this bug go to: