← Back to team overview

kernel-packages team mailing list archive

[Bug 1570820] Re: Suspend failure


So I just found this site "Ubuntu to Mainline kernel version mapping"
that the official 4.4.0-18 kernel is based upon the updstream 4.4.6
kernel. So I just tried installing that version and suspend is broken.
So this is something this must be something that was fixed upstream
between 4.4.6 and 4.4.7.

I'm not knowledgeable enough to go through all the commits between 4.4.6
and 4.4.7 and find out exactly which one fixed the bug so that you can
create a patch for it. However, I did find out that the word "suspend"
is mentioned a few times in the 4.4.7's changelog:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.7 So maybe
someone else can pick up whatever is needed to fix the kernel suspend
issues that I'm facing and import it as a patch to the official kernel.
Or maybe you can rebase the oficial kernel to the 4.4.7 version after
the oficial LTS release. I don't know if that's possible since I'm not
aware of the kernel update policy.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Suspend failure

Status in linux package in Ubuntu:

Bug description:
  My laptop fails to suspend. The screen turns off, but the fans
  continue to run (and it may actually get hotter). I wait and wait, and
  nothing happens (the power indicator remains always on).

  I tried suspending using the GUI, pressing the power button, closing
  the lid, and even through the terminal with the "pm-suspend" command.
  Nothing worked.

  Suspend worked fine on Ubuntu 15.10 and older releases, but since I
  upgraded to 16.04 I'm unable to put it to sleep.  In fact,  I had an
  old 4.2 kernel installed from Wily. I booted into it and it suspended
  and then resumed flawlessly, so it really seems to be a kernel related

  I'll gladly perform any testing procedures that you may need to try to
  identify what the problem may be.

  I really hope that you are able to fix this soon, even if it will
  probably after the final release.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-18-generic 4.4.0-18.34
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Uname: Linux 4.4.0-18-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC0:  pedro      2579 F.... pulseaudio
  CurrentDesktop: GNOME
  Date: Fri Apr 15 12:39:05 2016
  HibernationDevice: RESUME=UUID=761da9d5-d078-4fb5-a4fc-eff7de723b18
  InstallationDate: Installed on 2015-10-27 (170 days ago)
  InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 870Z5E/880Z5E/680Z5E
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic.efi.signed root=UUID=8d1874c5-ce9f-481e-8d2a-ce85da5cd7fe ro quiet splash vt.handoff=7
   linux-restricted-modules-4.4.0-18-generic N/A
   linux-backports-modules-4.4.0-18-generic  N/A
   linux-firmware                            1.157
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-04-09 (5 days ago)
  dmi.bios.date: 04/21/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P05ADH.017.140421.SH
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: NP870Z5E-X01PT
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: SEC_SW_REVISION_1234567890ABCD
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP05ADH.017.140421.SH:bd04/21/2014:svnSAMSUNGELECTRONICSCO.,LTD.:pn870Z5E/880Z5E/680Z5E:pvrP05ADH:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP870Z5E-X01PT:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
  dmi.product.name: 870Z5E/880Z5E/680Z5E
  dmi.product.version: P05ADH
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to: