← Back to team overview

kernel-packages team mailing list archive

[Bug 1569484] Re: Auto Ethernet connection profile appears. Wifi does not work anymore.


I've tried kernel 4.6rc3 to no avail (same machine, Dell XPS 13 9350).
The thing has the broadcom 4350 card.

I'm running a 4.4 lowlatency kernel on this machine, which is not
upgraded automatically or anything, so the problem can IMHO not come
from a kernel change, but it must be something network-manager (or
external driver) related.

The "error getting signal strenght" is only a consequence of the wifi
not being recognized as a wifi, but as an ethernet connection. Ethernet
doesn't have the parameter "signal strength".

The problem lies here:
docker0  bridge    verbunden        docker0    
wlp3s0   ethernet  verbunden        wlp3s0     

wlp3s0 is found to be an ethernet connection.

Since today also my MacBook Pro shows the same behaviour, with a
broadcom BCM43602.

I manage to get wifi running by defining the ssid/passphrase with wpa_passphrase, starting wpa_supplicant manually and then running dhclient on the interface and setting a nameserver in /etc/resolv.conf by hand.
I ordered an Intel wifi card for now, want to see if this changes anything.

Strange enough, every 26th (or something around that) will let the wifi
show up like it's supposed to, so the problem is really very hard to

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Auto Ethernet connection profile appears. Wifi does not work anymore.

Status in linux package in Ubuntu:

Bug description:
  I ran sudo apt-get upgrade && sudo apt-get dist-upgrade. Some
  installation have done and Auto Ethernet profile emerged in internet
  settings. After those installations I could not connect to internet.
  My laptop is Dell xps 13 9350.

  I used my TP-LINK wireless adapter to be able to send you this bug.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: network-manager-gnome 1.1.93-1ubuntu1
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Uname: Linux 4.4.0-18-generic x86_64
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Tue Apr 12 20:18:04 2016
  ExecutablePath: /usr/bin/nm-connection-editor
   # interfaces(5) file used by ifup(8) and ifdown(8)
   auto lo
   iface lo inet loopback
  InstallationDate: Installed on 2016-04-10 (1 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
   default via dev wlxc4e98417061b  proto static  metric 600 dev wlxc4e98417061b  scope link  metric 1000 dev wlxc4e98417061b  proto kernel  scope link  src  metric 600
  SourcePackage: network-manager-applet
  UpgradeStatus: No upgrade log present (probably fresh install)
   NAME          UUID                                  TYPE             TIMESTAMP   TIMESTAMP-REAL                 AUTOCONNECT  AUTOCONNECT-PRIORITY  READONLY  DBUS-PATH                                   ACTIVE  DEVICE           STATE      ACTIVE-PATH
   berkaywifi 1  3f5048a4-32e9-4ca5-ad31-f615ca2bc0e9  802-11-wireless  1460481455  Sal 12 Nis 2016 20:17:35 EEST  yes          0                     no        /org/freedesktop/NetworkManager/Settings/1  yes     wlxc4e98417061b  activated  /org/freedesktop/NetworkManager/ActiveConnection/1
   berkaywifi 2  6afc325f-3765-4687-b4dd-47c17a93f185  802-11-wireless  1460480549  Sal 12 Nis 2016 20:02:29 EEST  yes          0                     no        /org/freedesktop/NetworkManager/Settings/2  no      --               --         --
   DEVICE           TYPE      STATE         DBUS-PATH                                  CONNECTION    CON-UUID                              CON-PATH
   wlxc4e98417061b  wifi      connected     /org/freedesktop/NetworkManager/Devices/3  berkaywifi 1  3f5048a4-32e9-4ca5-ad31-f615ca2bc0e9  /org/freedesktop/NetworkManager/ActiveConnection/1
   wlp58s0          ethernet  disconnected  /org/freedesktop/NetworkManager/Devices/1  --            --                                    --
   lo               loopback  unmanaged     /org/freedesktop/NetworkManager/Devices/0  --            --                                    --
  nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

To manage notifications about this bug go to: