← Back to team overview

kernel-packages team mailing list archive

[Bug 1571535] Re: iwlwifi restarts randomly in xenial


While I'm not sure why this only appeared in xenial, I've told network
manager to prefer 2.4MHz for now in the hope that will help.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  iwlwifi restarts randomly in xenial

Status in linux package in Ubuntu:

Bug description:
  Recently installed xenial on a Lenovo Yoga 2-13 (Intel 7260 wifi
  card).  On wily it worked perfectly, on xenial it regularly appears to
  restart the wifi connection (the end result is that I lose any vpn
  connections, as they don't seem to notice the restart, but that's
  another issue).

  In general use, I get periodic "wlp1s0: WPA: Group rekeying completed"
  messages in syslog (and used to get these in wily, too), but now,
  after a random amount of time (over the weekend it was several hours,
  this morning it was about 10 minutes, so it might be related to the
  amount of network traffic) I get "kernel: [13983.248157] wlp1s0:
  authenticate with 00:8a:ae:c9:9a:d8" (presumably my wifi router) and
  the usual wifi startup stuff including frequency lists, etc.

  It also always logs "systemd-udevd[30319]: Process '/sbin/crda' failed
  with exit code 249." every time (I'm not sure if this is relevant)

  After reading old, but similar bug reports, I've tried changing some
  of the module options: "11n_disable=1" and "11n_disable=8", but these
  had no effect.  I've also tried the older firmware that wily used
  (/lib/firmware/iwlwifi-7260-13.ucode), but again, no improvement.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-18-generic 4.4.0-18.34
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Uname: Linux 4.4.0-18-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC0:  chris      7058 F.... pulseaudio
   /dev/snd/controlC1:  chris      7058 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Mon Apr 18 09:01:26 2016
  HibernationDevice: RESUME=UUID=f92d915f-d552-4e5b-989d-70e936ce4f74
  InstallationDate: Installed on 2016-04-14 (3 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
  MachineType: LENOVO 20344
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-18-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro noprompt quiet splash vt.handoff=7
   linux-restricted-modules-4.4.0-18-generic N/A
   linux-backports-modules-4.4.0-18-generic  N/A
   linux-firmware                            1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/09/2014
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 96CN25WW(V1.11)
  dmi.board.asset.tag: 31900058WIN
  dmi.board.name: INVALID
  dmi.board.vendor: LENOVO
  dmi.board.version: 31900058WIN
  dmi.chassis.asset.tag: 31900058WIN
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo Yoga 2 13
  dmi.modalias: dmi:bvnLENOVO:bvr96CN25WW(V1.11):bd07/09/2014:svnLENOVO:pn20344:pvrLenovoYoga213:rvnLENOVO:rnINVALID:rvr31900058WIN:cvnLENOVO:ct10:cvrLenovoYoga213:
  dmi.product.name: 20344
  dmi.product.version: Lenovo Yoga 2 13
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: