← Back to team overview

kernel-packages team mailing list archive

[Bug 1562618] Re: whole OS freezes seemingly randomly



I think I got a little further!
The 4.4.0-21 seemed to work flawlessly, untill I found out that when enabling bluetooth I got the freezes.
It even worked fine at first, but because the sound was crappy I changed the headphones profile to A2DP and then the freezes started as soon as I had network traffic by file transfer!

I can reproduce the freeze now by simply ding a file transfer over the network (over wifi) and then enable bluetooth.
In the 4.4.0 and the 4.6.0 the bluetooth patch is present that tries to load the driver and the BCM.hcd file in /lib/firmware/brcm/ .
This explains why the 4.2.0 kernel :
4.2.0-040200-generic #201510260713 SMP Mon Oct 26 11:14:43 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
seems to run fine, because it does not load any bluetooth driver.
On that one I see from dmesg:
[    7.274842] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    7.274854] Bluetooth: BNEP filters: protocol multicast
[    7.274870] Bluetooth: BNEP socket layer initialized

On the 4.4.21 with the bt support I see:
[   14.519814] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   14.519821] Bluetooth: BNEP filters: protocol multicast
[   14.519828] Bluetooth: BNEP socket layer initialized
[   15.524279] Bluetooth: hci0: BCM: Reading local version info failed (-110)
[   15.589273] Bluetooth: hci0: BCM: chip id 70
[   15.605441] Bluetooth: hci0: BCM43142A
[   15.605450] Bluetooth: hci0: BCM (001.001.011) build 0000
[   16.218220] Bluetooth: hci0: BCM (001.001.011) build 0172
[   16.235944] Bluetooth: hci0: Broadcom Bluetooth Device (43142)

The strange this is that it seems to have something to do with the audio profile. 
It all worked fine with just crappy bluetooth audio until I tried to change the profile.
Strange there was that it didn't work neatly either, it required putting switches on and off and sometimes reloading the btusb driver.

Anyway, since I seem to have something reproducable, how can I proceed?
Thank you for the help!

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  whole OS freezes seemingly randomly

Status in linux package in Ubuntu:

Bug description:
  I had some random freezes of the whole operating system.
  No caps lock response or terminal switching, nothng.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-15-generic 4.4.0-15.31
  ProcVersionSignature: Ubuntu 4.4.0-15.31-generic 4.4.6
  Uname: Linux 4.4.0-15-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  vincent    1714 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Sun Mar 27 23:46:02 2016
  HibernationDevice: RESUME=UUID=8180a7b6-a1c0-494a-9f65-99a7b54f6deb
  InstallationDate: Installed on 2015-11-01 (147 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: LENOVO 20332
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-15-generic.efi.signed root=UUID=44fb018f-3dbd-4eb6-ab9a-6668de8d13d2 ro quiet splash vt.handoff=7
   linux-restricted-modules-4.4.0-15-generic N/A
   linux-backports-modules-4.4.0-15-generic  N/A
   linux-firmware                            1.157
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-03-25 (2 days ago)
  dmi.bios.date: 12/26/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 92CN26WW(V1.06)
  dmi.board.asset.tag: NO Asset Tag
  dmi.board.name: AIUU1
  dmi.board.vendor: LENOVO
  dmi.board.version: 31900042STD
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo Yoga 2 11
  dmi.modalias: dmi:bvnLENOVO:bvr92CN26WW(V1.06):bd12/26/2013:svnLENOVO:pn20332:pvrLenovoYoga211:rvnLENOVO:rnAIUU1:rvr31900042STD:cvnLENOVO:ct10:cvrLenovoYoga211:
  dmi.product.name: 20332
  dmi.product.version: Lenovo Yoga 2 11
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: