← Back to team overview

kernel-packages team mailing list archive

[Bug 1568865] Re: [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]] *ERROR* CPU pipe B FIFO underrun


Actually I just tried the 4.6 kernel that was officially released 2 days
ago, and I still get a freeze when attaching monitor to HDMI.    However
the symptoms are different.

The external monitor does get the desktop drawn on it, and I can move
the mouse around, and between the monitors.  But the interface is
otherwise frozen:  the clock on the screen stops "ticking" and no
windows can be interacted with.  Also cannot hit CTRL+ALT+F3 to get to a
tty screen.

Furthermore the logging in syslog is different:

May 18 13:29:58 squan /usr/lib/gdm3/gdm-x-session[1313]: (--) intel(0): HDMI max TMDS frequency 300000KHz
May 18 13:29:58 squan /usr/lib/gdm3/gdm-x-session[1313]: (II) intel(0): resizing framebuffer to 7680x2160
May 18 13:29:58 squan /usr/lib/gdm3/gdm-x-session[1313]: (II) intel(0): switch to mode 3840x2160@60.0 on eDP1 using pipe 1, position (0, 0), rotation normal, reflection none
May 18 13:29:59 squan /usr/lib/gdm3/gdm-x-session[1313]: (II) intel(0): switch to mode 3840x2160@30.0 on HDMI1 using pipe 0, position (3840, 0), rotation normal, reflection none
May 18 13:29:59 squan /usr/lib/gdm3/gdm-x-session[1313]: (--) intel(0): HDMI max TMDS frequency 300000KHz
May 18 13:30:04 squan systemd[1]: Starting Stop ureadahead data collection...
May 18 13:30:04 squan systemd[1]: Stopped Read required files in advance.
May 18 13:30:04 squan systemd[1]: Started Stop ureadahead data collection.
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) [mi] EQ overflowing.  Additional events will be discarded until existing events are processed.
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE)
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) Backtrace:
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4e) [0x55e9082ae50e]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 1: /usr/lib/xorg/Xorg (mieqEnqueue+0x253) [0x55e90828ffd3]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 2: /usr/lib/xorg/Xorg (QueuePointerEvents+0x52) [0x55e908168672]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 3: /usr/lib/xorg/Xorg (xf86PostMotionEvent+0xd6) [0x55e90819fb56]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 4: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f50831b1000+0x6056) [0x7f50831b7056]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 5: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f50831b1000+0x7682) [0x7f50831b8682]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 6: /usr/lib/xorg/Xorg (0x55e9080fc000+0x94248) [0x55e908190248]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 7: /usr/lib/xorg/Xorg (0x55e9080fc000+0xb9712) [0x55e9081b5712]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 8: /lib/x86_64-linux-gnu/libc.so.6 (0x7f508c80d000+0x354a0) [0x7f508c8424a0]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 9: /usr/lib/xorg/Xorg (0x55e9080fc000+0x1b6cf0) [0x55e9082b2cf0]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 10: /lib/x86_64-linux-gnu/libc.so.6 (0x7f508c80d000+0x354a0) [0x7f508c8424a0]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 11: /lib/x86_64-linux-gnu/libc.so.6 (ioctl+0x7) [0x7f508c909687]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 12: /usr/lib/x86_64-linux-gnu/libdrm.so.2 (drmIoctl+0x28) [0x7f508dbef0f8]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 13: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f50889e1000+0x763ea) [0x7f5088a573ea]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 14: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f50889e1000+0x106c39) [0x7f5088ae7c39]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 15: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f50889e1000+0x108571) [0x7f5088ae9571]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 16: /usr/lib/xorg/Xorg (DRI2SwapBuffers+0x1c8) [0x55e908280a98]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 17: /usr/lib/xorg/Xorg (0x55e9080fc000+0x18632c) [0x55e90828232c]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 18: /usr/lib/xorg/Xorg (0x55e9080fc000+0x53bbf) [0x55e90814fbbf]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 19: /usr/lib/xorg/Xorg (0x55e9080fc000+0x57c43) [0x55e908153c43]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 20: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf0) [0x7f508c82d830]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) 21: /usr/lib/xorg/Xorg (_start+0x29) [0x55e90813df59]
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE)
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) [mi] mieq is *NOT* the cause.  It is a victim.
May 18 13:30:05 squan /usr/lib/gdm3/gdm-x-session[1313]: (EE) [mi] EQ overflow continuing.  100 events have been dropped.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]] *ERROR* CPU pipe
  B FIFO underrun

Status in linux package in Ubuntu:

Bug description:
  Running Gnome-Shell on ubuntu 16.04 on my Dell XPS 15 9550 laptop
  using Intel graphics (Nvidia card turned off), I get this error in
  syslog when plugging in an external monitor (HDMI).

  Apr 11 14:28:38 miaco kernel: [ 2616.604641]
  [drm:intel_cpu_fifo_underrun_irq_handler [i915_bpo]] *ERROR* CPU pipe
  B FIFO underrun

  Meanwhile both screens flash and show corruption. Most of the time
  this has caused a hang that needs a hard power off to get out of, but
  occasionally removing the external monitor is enough to get going
  again and so I've been able to find this message in the logs.

  Note that when using Nvidia (proprietary) drivers and Unity DE I do
  not have this problem; so it seems to be related to the intel drivers,
  or possibly Gnome Shell's use of them.

  Happy to help if I can (would like to be able to use external


  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-18-generic 4.4.0-18.34
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Uname: Linux 4.4.0-18-generic x86_64
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
   /dev/snd/controlC0:  rich       1943 F.... pulseaudio
  Date: Mon Apr 11 14:31:26 2016
  InstallationDate: Installed on 2016-03-21 (21 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160307)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 003: ID 04f3:21d5 Elan Microelectronics Corp. 
   Bus 001 Device 002: ID 0a5c:6410 Broadcom Corp. 
   Bus 001 Device 004: ID 0c45:6713 Microdia 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. XPS 15 9550
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-18-generic.efi.signed root=UUID=3f8391d5-e9cc-4768-8efb-8f04d340567c ro quiet splash vt.handoff=7
   Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
   No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-4.4.0-18-generic N/A
   linux-backports-modules-4.4.0-18-generic  N/A
   linux-firmware                            1.157
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/25/2016
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 01.01.19
  dmi.board.name: 0N7TVV
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvr01.01.19:bd01/25/2016:svnDellInc.:pnXPS159550:pvr:rvnDellInc.:rn0N7TVV:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 15 9550
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: