← Back to team overview

kernel-packages team mailing list archive

[Bug 1590798] Re: Can't connect/pair Bose Soundlink II Headphones to Ubuntu 16.04


*** This bug is a duplicate of bug 1589889 ***

I have followed the fix suggestion in bug #1589889. This has resulted in
some progress in that I can now connect to the headphones, and once the
headphones did register the laptop. But they disconnected straight away,
and hasn't registered again since then.

I've tried the blueman manager as it tends to put out a bit more
information than the standard bluetooth manager and i get the following:

Connection Failed: blueman.bluez.errors.DBusFailedError: Protocol not

This device registers as several different components and when I
specifically try to connect to the serial port I get the following

Connection Failed: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/blueman/services/meta/SerialService.py", line 29, in connect
    port_id = create_rfcomm_device(Adapter(props['Adapter']).get_properties()['Address'], props['Address'], 1)
  File "_blueman.pyx", line 218, in _blueman.create_rfcomm_device (_blueman.c:2127)
Exception: Can't connect RFCOMM socket

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  Can't connect/pair Bose Soundlink II Headphones to Ubuntu 16.04

Status in bluez package in Ubuntu:

Bug description:
  I've recently started using 16.04 on a Dell XPS 15 9550 and I'm unable
  to pair my Bose Soundlink II headphones. I've tried using the stock
  and blueman bluetooth managers and neither will work.

  When I use bluetoothctl and run "pair [Device ID]" I get the following

  Failed to pair: org.bluez.Error.AuthenticationFailed

  I have seen several references to this online but believe there are
  still problems in 16.04

    Installed: 5.37-0ubuntu5
    Candidate: 5.37-0ubuntu5
    Version table:
   *** 5.37-0ubuntu5 500
          500 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
          100 /var/lib/dpkg/status

To manage notifications about this bug go to: