← Back to team overview

kernel-packages team mailing list archive

[Bug 1228406] Re: [LENOVO 3249CTO] suspend/resume failure


So, here's something funny.  The suspend/resume failures started
happening for me on September 20, almost exactly 3 years after I'd
gotten the machine; and was reproducible with older kernels and OSes
that had previously worked fine.  I had joked that maybe the BIOS had a
time bomb in it, or just knew its time was up because I was due for a
laptop refresh, and decided to try setting the BIOS clock back to before
September 20th to see if it made any difference.

I set the BIOS clock back exactly 3 months, to September 2.  I have now
had 8 successful suspend/resumes in a row with no problems.  After the
third suspend/resume, I set the clock back to the current date and the
problem has still not recurred.

I have no idea why this actually made a difference, of course; but it
seems to have done so.

I guess this bug should be closed as invalid, unless you're interested
in having me poke this BIOS harder, Colin.

** Changed in: linux (Ubuntu)
       Status: Confirmed => Invalid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [LENOVO 3249CTO] suspend/resume failure

Status in “linux” package in Ubuntu:

Bug description:
  The laptop frequently suspends/resumes successfully; it's been
  suspended/resumed probably at least a dozen times since the last
  reboot.  I've seen intermittent suspend/resume failures before with
  previous kernel versions.

  ProblemType: KernelOops
  DistroRelease: Ubuntu 13.10
  Package: linux-image-3.11.0-7-generic 3.11.0-7.14
  ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
  Uname: Linux 3.11.0-7-generic x86_64
  Annotation: This occured during a previous suspend and prevented it from resuming properly.
  ApportVersion: 2.12.4-0ubuntu1
  Architecture: amd64
   /dev/snd/controlC0:  vorlon     4171 F.... pulseaudio
   /dev/snd/pcmC0D0p:   vorlon     4171 F...m pulseaudio
  Date: Fri Sep 20 16:16:06 2013
  ExecutablePath: /usr/share/apport/apportcheckresume
  Failure: suspend/resume
  HibernationDevice: RESUME=UUID=f6ab3c43-61b4-4af7-bf03-fa3b147a1de0
  InstallationDate: Installed on 2010-09-24 (1092 days ago)
  InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
  InterpreterPath: /usr/bin/python3.3
   Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 3249CTO
  MarkForUpload: True
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-7-generic root=/dev/mapper/hostname-root ro quiet splash vt.handoff=7
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: Daemon not responding.
   linux-restricted-modules-3.11.0-7-generic N/A
   linux-backports-modules-3.11.0-7-generic  N/A
   linux-firmware                            1.114
  SourcePackage: linux
  Title: [LENOVO 3249CTO] suspend/resume failure
  UpgradeStatus: Upgraded to saucy on 2013-05-06 (137 days ago)
  dmi.bios.date: 08/23/2010
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6QET52WW (1.22 )
  dmi.board.name: 3249CTO
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvr6QET52WW(1.22):bd08/23/2010:svnLENOVO:pn3249CTO:pvrThinkPadX201:rvnLENOVO:rn3249CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 3249CTO
  dmi.product.version: ThinkPad X201
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: