← Back to team overview

kernel-packages team mailing list archive

[Bug 1030123] Re: 8086:0085 Ad-Hoc wlan broken


Mikko Rauhala, this bug was reported a while ago and there hasn't been
any activity in it recently. We were wondering if this is still an
issue? If so, could you please test for this with the latest development
release of Ubuntu? ISO images are available from
http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue,please just make a comment to this.

** Changed in: linux (Ubuntu)
       Status: Triaged => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  8086:0085 Ad-Hoc wlan broken

Status in “linux” package in Ubuntu:

Bug description:
  Ad Hoc wlan (hotspot) is completely broken for linux-
  image-3.2.0-27-generic at least on my particular hardware. The bug
  report says -24 because ubuntu-bug didn't allow me to edit that and
  I'm running -24 as a workaround. No problem there.  I tried linux-
  image-3.2.0-26-generic to pinpoint the bug's appearance. It worked.

  Adapter is 03:00.0 Network controller: Intel Corporation Centrino
  Advanced-N 6205 (rev 34)

  Snippet of syslog representative of the problem, under -27:

  Jul 27 22:47:31 t420s-4 wpa_supplicant[1752]: Trying to associate with SSID 't420s-4'
  Jul 27 22:47:31 t420s-4 kernel: [   92.126605] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
  Jul 27 22:47:31 t420s-4 kernel: [   92.126821] iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
  Jul 27 22:47:31 t420s-4 wpa_supplicant[1752]: nl80211: Failed to set interface into IBSS mode
  Jul 27 22:47:31 t420s-4 wpa_supplicant[1752]: Association request to the driver failed
  Jul 27 22:47:31 t420s-4 kernel: [   92.250848] ADDRCONF(NETDEV_UP): wlan0: link is not ready
  Jul 27 22:47:41 t420s-4 wpa_supplicant[1752]: Authentication with 00:00:00:00:00:00 timed out.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-24-generic 3.2.0-24.39
  ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
  Uname: Linux 3.2.0-24-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu11
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: PCH [HDA Intel PCH], device 0: CONEXANT Analog [CONEXANT Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  mjrauhal   2794 F.... pulseaudio
  CRDA: Error: [Errno 2] No such file or directory
   Card hw:0 'PCH'/'HDA Intel PCH at 0xf1620000 irq 50'
     Mixer name	: 'Intel CougarPoint HDMI'
     Components	: 'HDA:14f1506e,17aa21d2,00100002 HDA:80862805,80860101,00100000'
     Controls      : 26
     Simple ctrls  : 8
   Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
     Mixer name	: 'ThinkPad EC (unknown)'
     Components	: ''
     Controls      : 1
     Simple ctrls  : 1
   Simple mixer control 'Console',0
     Capabilities: pswitch pswitch-joined penum
     Playback channels: Mono
     Mono: Playback [on]
   Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
   dmesg: write failed: Broken pipe
  Date: Fri Jul 27 23:31:57 2012
  MachineType: LENOVO 4173L7G
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-24-generic root=/dev/mapper/t420s--4-root ro quiet splash vt.handoff=7
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)

  dmi.bios.date: 09/14/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8CET49WW (1.29 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 4173L7G
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvr8CET49WW(1.29):bd09/14/2011:svnLENOVO:pn4173L7G:pvrThinkPadT420s:rvnLENOVO:rn4173L7G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 4173L7G
  dmi.product.version: ThinkPad T420s
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: