← Back to team overview

kernel-packages team mailing list archive

[Bug 1202047] Re: Realtek Barossa PCI Express SD card reader no longer working, rts_pstor module missing


Carlos Montalvo, as per http://h10025.www1.hp.com/ewfrf/wc/softwareCategory?os=4062&lc=en&cc=us&dlc=en&sw_lang=&product=4323444#N1344 an update is available for your BIOS (F.15). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything? If it doesn't, could you please both specify what happened, and just provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so
posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see

Thank you for your understanding.

** Tags added: bios-outdated-f.15

** Tags added: saucy

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Realtek Barossa PCI Express SD card reader no longer working,
  rts_pstor module missing

Status in “linux” package in Ubuntu:

Bug description:
  The card reader is recognized (eg. via lspci), but the system doesn't
  detect nor mount any SD card.

  It was working fine with the previous Quantal kernel, using the
  rts_pstor module. I remember reading about this module having been
  removed from upstream kernel source since version 3.8.0.

  I have tried loading the following modules manually with modprobe, but
  none of them seem to work: rtsx_pci_sdmmc, rts5139, rtsx_pci

  Another thing I've tried is to compile the rts_pstor module from a
  source tarball downloaded from Realtek's website. However, the module
  fails to compile, I believe it's because the source hasn't been
  updated since 2012 and so assumes an older kernel version. I have
  included the original tarball from Realtek as an attachment.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.04
  Package: linux-image-3.8.0-26-generic 3.8.0-26.38
  ProcVersionSignature: Ubuntu 3.8.0-26.38-generic
  Uname: Linux 3.8.0-26-generic x86_64
  ApportVersion: 2.9.2-0ubuntu8.1
  Architecture: amd64
   /dev/snd/controlC0:  carlos     2078 F.... pulseaudio
  Date: Tue Jul 16 21:25:11 2013
  EcryptfsInUse: Yes
  GvfsMonitorLog: Monitoring events. Press Ctrl+C to quit.
  HibernationDevice: RESUME=UUID=99bdf4ab-cb9c-4a96-8cda-97ea34e9572b
  InstallationDate: Installed on 2012-10-31 (258 days ago)
  InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
  MachineType: Hewlett-Packard Compaq Mini CQ10-400
  MarkForUpload: True
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-26-generic root=UUID=0788b9a6-56d9-4652-beb6-772a9688f512 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.8.0-26-generic N/A
   linux-backports-modules-3.8.0-26-generic  N/A
   linux-firmware                            1.106
  SourcePackage: linux
  Symptom: storage
   monitor will print the received events for:
   UDEV - the event which udev sends out after rule processing
   Monitoring the udisks daemon. Press Ctrl+C to exit.
   21:25:25.642: The udisks-daemon is running (name-owner :1.26).
  UpgradeStatus: Upgraded to raring on 2013-04-25 (82 days ago)
  dmi.bios.date: 08/17/2010
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: F.13
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: 148A
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: 79.49
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnHewlett-Packard:bvrF.13:bd08/17/2010:svnHewlett-Packard:pnCompaqMiniCQ10-400:pvr049E100000202400110300000:rvnHewlett-Packard:rn148A:rvr79.49:cvnHewlett-Packard:ct10:cvrChassisVersion:
  dmi.product.name: Compaq Mini CQ10-400
  dmi.product.version: 049E100000202400110300000
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to: