← Back to team overview

kernel-packages team mailing list archive

[Bug 1119842] Re: Broadcom 802.11ac [14e4:43b1]: wireless doesn't work after bcmwl-kernel-source installed, suspend/resume/shutdown failure


Hi everyone

I've installed Ubuntu 13.10 (Desktop AMD 64 bits - Kernel 3.11.0-17)
last week and had the some problem reported by Gabriel (fails to reboot
and to power off ;  wireless card is not recognized).

I have a laptop Dell Latitude D830 with a Dell Wireless 1390 WLAN
Minicard (chipset Broadcom BCM 4311 802.11 b/g), since 2007.

I had the latest available version of the 'bcmwl-kernel-source' package
(Version:, which was automatically
installed with Ubuntu. Since I couldn't have it working at any cost, I
removed this package and installed 'linux-firmware-nonfree' (Non-free
firmware for Linux kernel drivers) (Version: 1.14ubuntu1),
'b43-fwcutter' (utility for extracting Broadcom 43xx firmware) (Version:
1:017-2) and 'firmware-b43-installer' (firmware installer for the b43
driver) (Version: 1:017-2), what solved my problem perfectly.

I've also tested other Ubuntu versions on this machine (12.04 LTS AMD64,
13.04 AMD64 and 13.10 i386) and had the exact same problem. However, in
2009 when I had Ubuntu 9.04 (Jaunty Jackalope) this issue wasn't
present. This Broadcom's open-source driver (bcmwl-kernel-source) was
released right after on that same year, for Ubuntu 9.10 (Karmic Koala).

When you do a bug-report search, right from this Launchpad Ubuntu Bug
platform, with the statement "bcmwl-kernel-source", 37 reports are
returned, dating from 2010 until now. It seems that this issue is
chronic , which ramains since the package was released. I don't know how
many kernels and device models are incompatible with this Broadcom
driver, neither if it's just a driver version issue or if it's the
driver itself (all versions) that is not well adapted to the kernel.

To be honest, I took a week to find where the problem was and make my
system work properly. Probably, if I wasn't a free software (open
source-code) and Linux/Ubuntu enthusiast, I would have given up at the
begening and returned to the convenience of Windows. Failure to have the
wireless card working and to reboot and power off properly, are serious
problems that may discourage novice users to adopt Ubuntu.

Perhaps there should be created a Graph linking the members of the three
groups involved in the issue: hardware device model, kernel version and
Broadcom driver version. Members among diferent groups would be linked
to each other when a bug between them is present and unsolved. A Graph
grafical representation (Graph diagram) could be usefull to help to map
and clarify this problem.

I am glad to be a Linux/Ubuntu user and a member of this Ubuntu
community! I hope I have helped somehow!


You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bcmwl in Ubuntu.

  Broadcom 802.11ac [14e4:43b1]: wireless doesn't work after bcmwl-
  kernel-source installed, suspend/resume/shutdown failure

Status in Broadcom Feature Request and Bug Reporting:
Status in HWE Next Project:
Status in “bcmwl” package in Ubuntu:

Bug description:
  This laptop has a Broadcom 802.11ac chip with a pci signature of
  [14e4:43b1]. When I install the bcmwl-kernel-source (as suggested by
  "Software Sources", suspend/resume no longer works and the laptop
  hangs when I try to shut it down. And to add insult to injury, my
  wireless card still doesn't work.

  ProblemType: KernelOops
  DistroRelease: Ubuntu 13.04
  Package: linux-image-3.8.0-5-generic 3.8.0-5.10
  ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
  Uname: Linux 3.8.0-5-generic x86_64
  NonfreeKernelModules: nvidia
  Annotation: This occured during a previous suspend and prevented it from resuming properly.
  ApportVersion: 2.8-0ubuntu4
  Architecture: amd64
   /dev/snd/controlC1:  gabbe      1989 F.... pulseaudio
   /dev/snd/controlC0:  gabbe      1989 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
  Date: Fri Feb  8 22:30:47 2013
  ExecutablePath: /usr/share/apport/apportcheckresume
  Failure: suspend/resume
  HibernationDevice: RESUME=UUID=7c89059e-2ea6-4ac1-bef4-d2fb9001403b
  InstallationDate: Installed on 2013-02-05 (3 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130204.1)
  InterpreterPath: /usr/bin/python3.3
   eth0      no wireless extensions.
   lo        no wireless extensions.
  MarkForUpload: True
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
   PATH=(custom, no user)
  ProcFB: 0 EFI VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-5-generic.efi.signed root=UUID=57371a00-0a44-449d-af53-ab7dbd7f8f69 ro quiet splash
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.8.0-5-generic N/A
   linux-backports-modules-3.8.0-5-generic  N/A
   linux-firmware                           1.100
  SourcePackage: linux
  Title: [ASUSTeK COMPUTER INC. G75VX] suspend/resume failure [non-free: nvidia]
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/24/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: G75VX.205
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: G75VX
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrG75VX.205:bd12/24/2012:svnASUSTeKCOMPUTERINC.:pnG75VX:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnG75VX:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: G75VX
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to: