← Back to team overview

kernel-packages team mailing list archive

[Bug 1331860] Missing required logs.


This bug is missing log files that will aid in diagnosing the problem.
>From a terminal window please run:

apport-collect 1331860

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  wireless lags

Status in “linux” package in Ubuntu:

Bug description:

  i already discussed the following issue already in the german forum
  and in your Official Ubuntu IRC Support Channel, without a solution.

  new Ubuntu: 14.04 LTS
  new Kernel: 3.13.0-29-generic
  old Ubuntu: 13.10
  old Kernel: 3.11.0-19-generic

  wireless device: TP-LINK WND4800, Atheros chipset
  wireless driver: ath9k
  wireless operating mode: 2.4ghz @ 802.11bgn and 5ghz @ 802.11a+n
  wireless router: fritz!box 3390

  Before upgrading to Ubuntu 14.04 LTS everything worked fine.
  After upgrading to Ubuntu 14.04 LTS the wireless connection produced sequently lags, when sending a ping to my wireless router.
  The lag sequence duration is around 5 seconds, the duration to the next lag sequence is around 100 seconds.
  Each ping get a reply (no requests get lost), but the delay of the reply raises up to 2000 miliseconds. 
  Normally the ping is around 1 or 2 miliseconds.
  I can reproduce this behavior manually by running 'sudo iwlist wlan1 scan' and keep watching the ping in another terminal window.
  I also used 'iwevent' to watch on events fired by the wireless interface while the lag is happening:
  '01:31:13.289166   wlan1    Scan request completed' is the only message i get.

  When booting the 3.11 kernel everything works fine again, no lags occur.
  If i try to reproduce the behavior with a manual scan as described before, no lags occur, everything keeps working fine.

  I already tried several configurations using special driver options like "nohwcrypt" and "debug", but dmesg and syslog do not log any failures or warnings.
  If i downgrade the wireless router to 2.4ghz @ 802.11b+g (54mbit) the new kernel (3.13) has also no failed pings and no massive lags, but this is not a stable solution for me due to many other wireless networks in my environment.

  So i assume there has been something changed between the kernel 3.11 and 3.13 or the belonging ath9k driver.
  I thought about the wireless scanning interval of the network manager, but i think changing this would also be just a workaround than a clean solution.

  Any ideas or recommendations how to solve this or how to collect more
  relevant information about this issue?

To manage notifications about this bug go to: