← Back to team overview

kernel-packages team mailing list archive

[Bug 1397277] Re: [HP ProBook 4740s] Kernel dead after suspend/resume at i915


I'm sorry, but this is not my notebook and I can't constantly test and
reboot it, so I revert to Ubuntu kernel and can't continue massive test
upstream kernel and dialog with kernel team. If any ideas to workaround
- please post it here...

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [HP ProBook 4740s] Kernel dead after suspend/resume at i915

Status in linux package in Ubuntu:

Bug description:
  HP ProBook 4740s, new installation of Ubuntu

  lsb_release -rd
  Description:	Ubuntu 14.10
  Release:	14.10

  Linux HP 3.16.0-25-generic #33-Ubuntu SMP Tue Nov 4 12:06:54 UTC 2014
  x86_64 x86_64 x86_64 GNU/Linux

    Installed: 2:2.99.914-1~exp1ubuntu4.1
    Candidate: 2:2.99.914-1~exp1ubuntu4.1

  lshw -c video
         description: VGA compatible controller
         product: 2nd Generation Core Processor Family Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: msi pm vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:48 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:3000(size=64)

  Suspend by menu at right upper corner. Waits... Wake up by button. Wallpaper and logon screen is appeared, periodically I can login and begin work, but not more than 5 seconds and system completely freezed. I can stay at login screen without keypress and its freezed too after some seconds.
  No mouse, keyboard, led or ssh activity is allowed. Kernel dead.
  Using fglrx or fglrx-updates it's no problem with suspend and resume, while using discrete card (not workaround for me). 

  I disabled Radeon card (in BIOS) and using i915. All fglrx and fglrx-
  updates is completely removed, xorg-radeon too.

  kernel option i915.modeset=0 resumed without hangs (but with black
  screen), and nomodeset too.

  tried to create xorg.conf with uxa

  Section "ServerLayout"
      Identifier "layout"
      Screen 0 "screen" 0 0

  Section "Device"
      Identifier "intel"
      Driver "intel"
      Option "AccelMethod" "uxa"
      BusID "PCI:0@0:2:0"

  Section "Monitor"
      Identifier "monitor"
      Option "VendorName" "HP"
      Option "ModelName" "HP Monitor"
      Option "DPMS" "true"

  Section "Screen"
      Identifier "screen"
      Device "intel"
      Monitor "monitor"
      DefaultDepth 24
      SubSection "Display"
          Viewport   0 0
          Depth     24

  but hangs too :(

  Hibernation works without any problem.

  Tried latest Linux Mint (booting with usb-stick) - hangs on
  suspend/resume too. Sometimes ago can suspend/resume at Windows 7, but
  I hate this OS.

  I suffered to resolve this problem last three days...
  ApportVersion: 2.14.7-0ubuntu8
  Architecture: amd64
   /dev/snd/controlC0:  tanya      2021 F.... pulseaudio
  DistroRelease: Ubuntu 14.10
  HibernationDevice: RESUME=UUID=78c29686-130c-464e-8bac-ed2e2c92f55f
  InstallationDate: Installed on 2014-11-23 (5 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
  MachineType: Hewlett-Packard HP ProBook 4740s
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-25-generic root=UUID=40874dc3-d1cb-41b8-910e-a79ceaeb4855 ro noplymouth enable_mtrr_cleanup=1 resume=/dev/sda2 acpi_sleep=nonvs
  ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
   Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
   No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.16.0-25-generic N/A
   linux-backports-modules-3.16.0-25-generic  N/A
   linux-firmware                             1.138
  Tags:  utopic
  Uname: Linux 3.16.0-25-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  _MarkForUpload: True
  dmi.bios.date: 07/16/2013
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: 68IRR Ver. F.42
  dmi.board.name: 1846
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: KBC Version 58.1F
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: dmi:bvnHewlett-Packard:bvr68IRRVer.F.42:bd07/16/2013:svnHewlett-Packard:pnHPProBook4740s:pvrA1009D11:rvnHewlett-Packard:rn1846:rvrKBCVersion58.1F:cvnHewlett-Packard:ct10:cvr:
  dmi.product.name: HP ProBook 4740s
  dmi.product.version: A1009D11
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to: