← Back to team overview

kicad-developers team mailing list archive

Re: New part file format document.


On 12/14/2010 04:49 PM, Wayne Stambaugh wrote:
> I made some ,inor changes to clarify inherited vs base part and changed
> LPID names reflect local naming convention as suggested by Dick.
> Wayne

Wayne and others,

I coded the initial major portion of DIR_LIB_SOURCE this weekend.  I believe the design is still
holding water, so far.

The only thing that has come up is this age old issue of content in container, and names.

Let me generalize, so you can see it is not specific to this design.

Assume you have a C++ file, and you decide to put the name of the file INTO the file as a string.

You load that C++ text file, and save it by another name.

The file now lives in two *containers*. 

1) The text editor is a container, and it assigns a name to the text file in memory.

2) The filesystem is a container, and it assigns a name to the text file on disk.

Each container has its own understanding of the name of the content (i.e. text file).  A
disagreement has happened.  And it is not about the name in the editor and the name on disk.

It is about the name IN THE FILE, and the name in the editor and on disk.

Either of the two examples of "content (text file) within container" would suffice to make my point:

    as long as you put the name of the file in the file, there is always
    the potential for a disagreement between what the file's container
    thinks the content is named, and what the contained name says.

Therefore, we might want to re-think our Sweet token that we referred to as "NAME"

(part NAME [extends LPID]

and either drop it, since the Sweet string will always be in some kind of container, or realize that
this is not *really* the name of the part, the container will always chose that.

A useful comprimize is to conceptually or actually change NAME to SHORT_DESCRIPTION, but if you have
a description elsewhere, a short description may not be needed at all.

Think about it.  The only time when the container will not name the content, may be on the clipboard.

A fast answer is probably a wrong answer.  I've been thinking about it for a day and still need more
time to state the best solution.

I just know that the problem will exist as we now have things, and as stated, it is not a problem
unique to this design.

The container's name will always really dominate, since that is the mechanism used to find units of


Follow ups