kicad-developers team mailing list archive
Mailing list archive
Add menu item functions.
While I was adding the ability to enable and disable images in menu items, I
noticed that there are four (were eight) inline functions (ADD_MENUITEM_*) for
adding menu items. Each of these functions have a different parameter list so
have a unique name for each function is not necessary. I would like to change
the macro like naming convention from ADD_MENUITEM_* to AddMenuItem() (or
EdaAddMenuItem() if we are worried about naming collisions). This should make
menu building code a lot cleaner without any loss in readability. I'll even
throw in some fancy Doxygen comments for free. If no one objects, I'll knock
this out over the next few days.