← Back to team overview

kicad-developers team mailing list archive

Re: Add menu item functions.


On 08/30/2011 03:23 PM, Wayne Stambaugh wrote:
> While I was adding the ability to enable and disable images in menu items, I
> noticed that there are four (were eight) inline functions (ADD_MENUITEM_*) for
> adding menu items.  Each of these functions have a different parameter list so
> have a unique name for each function is not necessary.  I would like to change
> the macro like naming convention from ADD_MENUITEM_* to AddMenuItem() (or
> EdaAddMenuItem() if we are worried about naming collisions).  This should make
> menu building code a lot cleaner without any loss in readability.  I'll even
> throw in some fancy Doxygen comments for free.  If no one objects, I'll knock
> this out over the next few days.
> Wayne

Thanks, would have done it myself someday, given enough time.

I have often questioned their home, meaning the macros.h file.

I was trying to use as little of wxWidgets in the SWEET stuff as possible.  But
for some reason was forced into including macros.h.  Now it pulls in the
universe.  I think only true, GUI library independent macros might go in there. 
I'm not sure SWEET even builds anymore.

But if you can find a more wx related file for these, that might be good too. 
Not sure macros.h needs to be so wxWidgets centric.

No answers here, just gut feelings, at the moment.


Follow ups